Strange electical problem - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 (permalink) Old 03-07-2008, 10:53 AM Thread Starter
Intrepid Newbie
 
Join Date: Feb 2008
Location: Georgia
Posts: 6
Feedback: 0 / 0%
 
Strange electical problem

I finally replaced my sub-frame bushings, and now I'm having another problem. Every occasionally something odd will happen, and my windows will not roll up/down, the heat/ac won't come on, and my airbag light stays on. The only way to fix it that I have found is to disconnect the battery cable for a bit and reconnect it. Seems to clear out the problems.

It seems to happen whenever I am running the ac/heat and attempt to roll down a window. I'll experiment and see if I can nail down the exact cause, but I thought some one might have encounter similar symptoms and know the cause/fix for it.

Also, I don't know if this is related, but my Check Engine light has been on forever. I have been told that it is most like a bad oxygen sensor causing the light. I don't know but it has been on for a very long time, and the new problem just started.

Any suggestions that anyone could give would be greatly appreciated.

Oh yea, almost forgot
I have 97 Chrysler Concord, that I am unsure of the engine size (I think it's a 3.3 but I'm not certain) The car has about 100,000 miles on it.

Last edited by Z-man; 03-07-2008 at 10:55 AM.
Z-man is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-10-2008, 08:52 PM
Intrepid Newbie
 
Join Date: Mar 2008
Location: south
Posts: 1
Feedback: 0 / 0%
 
Electrical Problems

I have a car with the same symptoms - AC/Heater fan cuts out, airbag light comes on, and windows won't work. I can turn the engine off and everything's OK on the restart. I've been told it's an ignition switch problem and jiggling the key does fix it most of the time without a restart. Plan on replacing the switch very soon (like tomorrow) and will let you know it that fixes it.
1994owner is offline  
post #3 of 4 (permalink) Old 03-14-2008, 08:22 AM Thread Starter
Intrepid Newbie
 
Join Date: Feb 2008
Location: Georgia
Posts: 6
Feedback: 0 / 0%
 
Thanks man, lemme know how it goes.
Z-man is offline  
post #4 of 4 (permalink) Old 03-17-2008, 01:23 AM Thread Starter
Intrepid Newbie
 
Join Date: Feb 2008
Location: Georgia
Posts: 6
Feedback: 0 / 0%
 
Quote:
Originally Posted by 1994owner View Post
I have a car with the same symptoms - AC/Heater fan cuts out, airbag light comes on, and windows won't work. I can turn the engine off and everything's OK on the restart. I've been told it's an ignition switch problem and jiggling the key does fix it most of the time without a restart. Plan on replacing the switch very soon (like tomorrow) and will let you know it that fixes it.
How did it go?
Z-man is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome