Engine Turn Over Issue - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 5 (permalink) Old 10-16-2006, 03:20 PM Thread Starter
Intrepid Newbie
Join Date: Nov 2005
Posts: 10
Feedback: 0 / 0%
Engine Turn Over Issue

Hey, I am hoping that one of yall can help me with this problem. I think somethin is drainin my battery. In the mornin when I get up to go out I try to start my car it wont turn over. theres power to the accessories and all I hear is the starter clicking continuously when I have the key turned to start. Ive had the altenator checked while it was running its putting out 14.47 volts so im at a loss for anything else. Any other ideas would be great if you can help. Thanks
Eaglechef86 is offline  
Sponsored Links
post #2 of 5 (permalink) Old 10-16-2006, 04:13 PM
Join Date: Sep 2004
Posts: 138
Feedback: 0 / 0%
It's the contacts inside your starter, more than likely. Take it to a trusted starter/alternator shop and have the contacts replaced.
xxxxxxxxxxxxxxxxxxxxxxxxxxxxmhzjunkie is offline  
post #3 of 5 (permalink) Old 10-16-2006, 05:15 PM
Intrepid Newbie
newfielaw's Avatar
Join Date: Mar 2006
Location: deer lake nl canada
Posts: 12
Feedback: 0 / 0%
is it just when the car is cold or do it happend all the time
mine was the same way and the batt was no good after i had the starter replaced i found it out
newfielaw is offline  
post #4 of 5 (permalink) Old 10-16-2006, 05:40 PM
Intrepid Fan
chevyjr73's Avatar
Join Date: Apr 2004
Location: chesapeake,virginia
Posts: 166
Feedback: 0 / 0%
sounds like a bad battery to me, have it load tested.
chevyjr73 is offline  
post #5 of 5 (permalink) Old 10-16-2006, 06:37 PM
Join Date: Sep 2004
Posts: 138
Feedback: 0 / 0%
After rereading what you wrote, it appears that newfielaw and chevyjr73, may be right. If you turn your key switch to the start position, and it clicks once, then you release it and try again, and it clicks again, then it's the contacts in the starter.

If you turn the key to the start position and hold it there and it clicks continuously, then it's what newfielaw and chevyjr73 mentioned. I will add that it could also be your cables needs cleaning.
xxxxxxxxxxxxxxxxxxxxxxxxxxxxmhzjunkie is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Random Question

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome