Raybestos Monroe Quick Strut Review - Page 9 - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
Reply
 
LinkBack Thread Tools Rating: Thread Rating: 20 votes, 5.00 average. Display Modes
post #121 of 167 (permalink) Old 11-14-2012, 01:19 PM
Farticcus of Plenticcus
 
shadowvox6's Avatar
 
Join Date: Sep 2003
Location: 39.199138,-84.669778
Posts: 17,030
Feedback: 18 / 100%
                     
Those struts mounts will fail.
shadowvox6 is offline  
Sponsored Links
Advertisement
 
post #122 of 167 (permalink) Old 11-14-2012, 03:23 PM
Intrepid Pro
 
300maximilien's Avatar
 
Join Date: Jun 2007
Location: Cleveland, Ohio
Posts: 2,015
Feedback: 11 / 100%
                     
if they do I will be sure to report back
300maximilien is offline  
post #123 of 167 (permalink) Old 11-14-2012, 04:27 PM
Intrepid Pro
 
Scooter-Man's Avatar
 
Join Date: Dec 2006
Location: Va Beach, VA
Posts: 12,883
Feedback: 6 / 100%
                     
Craig - pull the cap covers off the struts and look to see which way the inner tabs are directed. The tabs are part of the mount. This will let you know if the correct mounts were used.

The passenger side should have the tabs going from a 2 to 8 o'clock direction.

The driver side should have the tabs going from a 10 to 4 o'clock direction.

See below (I just snapped these pictures)

Passenger side:


Driver's side:

70mm TB, True Dual Exhaust, 3:89 Gears, 300M Special Front and Rear Sway Bars
Scooter-Man is offline  
post #124 of 167 (permalink) Old 11-19-2012, 10:41 AM
Intrepid Modder
 
ronbiggs's Avatar
 
Join Date: May 2010
Location: ct
Posts: 427
Feedback: 0 / 0%
                     
Quote:
Originally Posted by Scooter-Man View Post
Craig - pull the cap covers off the struts and look to see which way the inner tabs are directed. The tabs are part of the mount. This will let you know if the correct mounts were used.

The passenger side should have the tabs going from a 2 to 8 o'clock direction.

The driver side should have the tabs going from a 10 to 4 o'clock direction.

See below (I just snapped these pictures)

Passenger side:


Driver's side:
So I am getting a clunking noise from the PS, and the steering is slow to return to center after a turn, so I suspect the strut mount from my Monroe Quick Strut (about 18 months old). Called the support line and they are sending me replacements for both sides. Before I install, I took off the caps and looked at the mounts compared to these pics. DS is the same, but the PS has the tabs at 4:00 & 10:00. Looks like it is rotated 1/4 turn clockwise compared to this pic. I installed it straight from the box

May be a dumb question, but do the mounts freely rotate 360 degrees?? Could/should I just rotate the mount before I install so that the tabs are in the correct position?

I'm gonna check the mount position on the new strut, but if it is the same as the one I have, just wondering if rotating the mount would work.

Also, while I am at it, I'm planning to replace the tension strut bushings. The FSM says not to re-use the bolts. Are these a dealer item?

Thanks!!!
ronbiggs is offline  
post #125 of 167 (permalink) Old 10-14-2013, 11:58 PM Thread Starter
I hit shit with sticks!


 
Daytrepper's Avatar
 
Join Date: Jan 2005
Location: Zebulon, NC
Posts: 34,211
Feedback: 20 / 100%
                     
Garage
Haha...just because I got pissed off again over re-reading this old thread...

22K miles as of today on the used Mopar struts I installed in the front from Dr. Tom....still solid, not even a sound...car rides good....funny clank noise from the "raybestos" rears...cant quite pinpoint it....but they are riding ok....

Monroe/Raybestos can go pound sand, still havent bought one of their products since this fiasco...I wont sell them at work either...BTW, the OEM I work for dropped Monroe in 2010 as an OEM supplier due to "excessive warranty claims"...they are now using Gabriel and Tokico as their OEM manufacturers.


1998 Dodge Intrepid
Ram Logistics Director; Danbo Truck & Diesel, Inc.
Proud sponsor of Just Junk It, LLC
President, Danbo Drumming Ventures, GmbH; Danbo-On-Drums

Last edited by Daytrepper; 10-15-2013 at 12:01 AM.
Daytrepper is offline  
post #126 of 167 (permalink) Old 10-15-2013, 01:19 AM
Intrepid Modder
 
Join Date: Oct 2012
Location: USA
Posts: 738
Feedback: 0 / 0%
                     
Serves them right. Buggers. I had to swap my struts four times due to this. Within 5K she'll clunk like a bitch on wheel turns.
SRT6INTREPID is offline  
post #127 of 167 (permalink) Old 10-16-2013, 12:04 PM
Intrepid Pro
 
300maximilien's Avatar
 
Join Date: Jun 2007
Location: Cleveland, Ohio
Posts: 2,015
Feedback: 11 / 100%
                     
Still rolling with no issues on the Blue Economatic Quick Struts. 20K on then and no noises.
300maximilien is offline  
post #128 of 167 (permalink) Old 02-16-2014, 11:27 PM
Intrepid Newbie
 
Join Date: Jan 2011
Location: Ohio
Posts: 18
Feedback: 0 / 0%
 
Quote:
Originally Posted by el_charal View Post
I've had the struts on my car since early 2011 and I've had them for about 75,000 miles (I had a loooooong commute to/from work) and I cannot tell a difference from now to the day I had them installed. It sucks because I paid a lot of money because I heard KYBs were the best struts. Not in my case. They're not bad they're ok but Idk about them being the "best". Probably would've been better off buying Mopar.
Can we get another update on how the KYB's are holding up? Also, did you use all KYB parts? Part numbers would be great too!

Sounds like they're holding up pretty well.

Thanks, Ron
isrb710 is offline  
post #129 of 167 (permalink) Old 03-07-2014, 03:22 AM
Intrepid Pro
 
Intrepidation's Avatar
 
Join Date: Oct 2009
Location: Athol, MA
Posts: 1,182
Feedback: 0 / 0%
                     
Ugh...well its been about a thousand miles and the replacement mounts have begun making noise. I've already got the replacement ones under warranty, but A.) its been so damn cold out I haven't had the drive to replace them and B.) I think I may just get OEM ones. This will be set #3. I was really hoping these "redesigned" mounts/bearings would you know, actually last, but nope. If anything they sound worse than originals in the Quick Struts did.

Monroe blames improper installation by the shop. When I asked why their mounts are the same on both sides while OEMS are 2 different ones He had no answer other than it shouldn't matter...right.

At this point I'd be better off getting used OEM mounts and bearing out of the junkyard than putting these new ones in again. Wish I had kept my old OEMs. The struts were rotting out but they never clunked while turning. Oh well, tome to get some new OEM mounts and bearings. I did say I'd report back on these "new and improved" mounts, and while the bearing may be improved, the mounts aren't. When I take them apart we'll see what the bearings look like.

Can't say I'm surprised by any of this, just disappointed.


The only thing dependable about the future is uncertainty.

Last edited by Intrepidation; 03-07-2014 at 04:11 AM.
Intrepidation is offline  
post #130 of 167 (permalink) Old 03-07-2014, 09:00 AM Thread Starter
I hit shit with sticks!


 
Daytrepper's Avatar
 
Join Date: Jan 2005
Location: Zebulon, NC
Posts: 34,211
Feedback: 20 / 100%
                     
Garage
Yep; thats what I ended up doing, getting used....funny, they are still doing fine even though I was told by Raybestos that my car is "bent" from an accident that its never been in. The used struts I got must have been bent to match it in the same accident.
Daytrepper is offline  
post #131 of 167 (permalink) Old 03-07-2014, 02:45 PM
Intrepid Pro
 
Intrepidation's Avatar
 
Join Date: Oct 2009
Location: Athol, MA
Posts: 1,182
Feedback: 0 / 0%
                     
Quote:
Originally Posted by Daytrepper View Post
Yep; thats what I ended up doing, getting used....funny, they are still doing fine even though I was told by Raybestos that my car is "bent" from an accident that its never been in. The used struts I got must have been bent to match it in the same accident.
Seems like the best interim solution for now, although I am curious about something I realized last night:



Intrepidation is offline  
post #132 of 167 (permalink) Old 03-07-2014, 11:52 PM
Intrepid Modder
 
Join Date: Nov 2006
Location: Woodbridge, VA
Posts: 520
Feedback: 0 / 0%
                     
Kyb

I'll be able to report back on the KYBs in the near future. I'm installing them on all four corners of my '99 LHS. But I only used the KYB struts. I used Moog strut isolators, the original springs, and the original strut mounts. I expect it to work well. It does ride a lot better, but not as stiff as a Special which is what I really wanted.
drynoc is offline  
post #133 of 167 (permalink) Old 10-25-2014, 03:16 PM
Intrepid Pro
 
KxWarrior's Avatar
 
Join Date: Jul 2012
Location: Harrisburg Area PA
Posts: 1,580
Feedback: 3 / 100%
                     
Garage
Throwing this in there due to desire to help out.

Purchased cheap cheap struts from Prime Choice auto back when I first got the car.

Passenger side went 5 months ago. Bearings fell out the bottom similar to the first post.

Then last month the drivers side went, loud popping in the mount.


Least it lasted almost 3 years.
KxWarrior is offline  
post #134 of 167 (permalink) Old 10-25-2014, 11:56 PM
Intrepid Newbie
 
Join Date: Jan 2011
Location: Ohio
Posts: 18
Feedback: 0 / 0%
 
Quote:
Originally Posted by isrb710 View Post
Can we get another update on how the KYB's are holding up? Also, did you use all KYB parts? Part numbers would be great too!

Sounds like they're holding up pretty well.

Thanks, Ron
El Charal, how about an update on the KYB's? And which specific parts were KYB?

Thanks, Ron
isrb710 is offline  
post #135 of 167 (permalink) Old 10-26-2014, 04:11 AM
Woober Goobers!

 
Ronbo's Avatar
 
Join Date: Mar 2005
Location: Tiny Pebble, AR
Posts: 39,969
Feedback: 44 / 100%
                     
Quote:
Originally Posted by isrb710 View Post
El Charal, how about an update on the KYB's? And which specific parts were KYB?

Thanks, Ron
Last Activity: 10-14-2014 11:32 AM

He lurks but doesn't post anymore.

I guarantee all the aftermarket strut mounts are crap! Save your time and money and buy the OEM strut mounts and bearings. Yes they're separate parts.

Then you can load up whatever strut cartridge you want and not have as many problems. By strut cartridge I mean just a strut itself and not a "Quickstrut". Again your best bet there is OEM.

A few have claimed success with Monroe Strut Cartridges, others KYB, etc.

How many times do you want to replace front suspension pieces in a very short period of time is up to you! That "Lifetime" warranty sounds good along with the cheap shit pricing on aftermarket until you have to replace those pieces 2-3 times a year and pay for an alignment!

Your choice!

"Just Junk It LLC."
Member of the Sold SRT-8 Magnums of DI.net Club!
Perky Jerky for Everyone!!
Crazy Rons House of Mega Deals
Ronbo is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome