Brake booster cold problem - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 (permalink) Old 12-15-2007, 07:54 PM Thread Starter
Intrepid Fan
 
frankiee's Avatar
 
Join Date: Dec 2007
Location: Ontario Canada
Posts: 141
Feedback: 0 / 0%
                     
Brake booster cold problem

1999 Intrepid
Cold morning problem
Got in car and no power brakes.
Took hose off the booster and there was lots of vacuum.
Let it warm up and then when the heat was on the floor they came back.
When they came back I could hear the "noise" of air when I pushed on the brakes.
I kept working them.
Noise went away and brakes are fine now.

I would say that it is the booster with a hole in the diaghram but why just when it is cold?

Any ideas!
frankiee is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-16-2007, 08:38 AM
Intrepid Modder
 
Join Date: Apr 2003
Location: Cape Cod
Posts: 251
Feedback: 0 / 0%
                     
Common problem....when cold!!!

1. Rubber seal on booster for brake pedal pushrod failure.....that's the hissing noise you're hearing....escaping vacuum.

2. Water enters booster and freezes.......bye bye brakes....

You NEED to replace the booster.
vega is offline  
post #3 of 4 (permalink) Old 12-16-2007, 09:36 AM Thread Starter
Intrepid Fan
 
frankiee's Avatar
 
Join Date: Dec 2007
Location: Ontario Canada
Posts: 141
Feedback: 0 / 0%
                     
Just happened agian this morning not 10 minites ago.
Thanks
I figured I had to replace the booster but was not sure.
So I cant replace the seal eh NOT....Why would I want a used booster that had water in it, stopping my family

Thanks for the experience sharing

I willl get a booster

I looked at my Haynes book and it dont look too hard to change.
I will be doing it myself
frankiee is offline  
post #4 of 4 (permalink) Old 12-16-2007, 10:02 AM
Intrepid Modder
 
Join Date: Apr 2003
Location: Cape Cod
Posts: 251
Feedback: 0 / 0%
                     
Yeah......forget about just trying to replace the seal.....I think the water in there is a result of condensation, not coming in thru the seal....the water is always in there.....and it freezes!

The book recommends getting a new retaining clip for the brake pedal to booster pushrod......they're cheap if you can easily get one.....I just was very careful with my old one and re-used it. Do yourself a favor and drop the dash panel below the steering column and you'll be able to get to the booster retaining bolts much easier.
vega is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome