severe electrical problems. - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 6 (permalink) Old 02-09-2017, 07:50 PM Thread Starter
Intrepid Modder
 
zerokool's Avatar
 
Join Date: Jul 2010
Location: Park city, Ut.
Posts: 613
Feedback: 1 / 100%
                     
Question severe electrical problems.

seams like my airbag, cruse control, taillights, horn and blinkers all stopped working simultaneously...

checked fuses and relays.

I'm thinking the bcm is bad, as my left turn signal was having issues before the motor swap, and the car has been sitting for almost 5 years while getting the stroker built.


id like to put in a 300m special dash I pulled. (and the rest of the wiring from the special, I pulled it all) but don't want to use the skim module. so I'm thinking a bcm from a regular trep,300, 'corde.

will this work like I'm thinking?
can dodge program a skim key without the car driving in? (lol)
zerokool is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-09-2017, 07:52 PM Thread Starter
Intrepid Modder
 
zerokool's Avatar
 
Join Date: Jul 2010
Location: Park city, Ut.
Posts: 613
Feedback: 1 / 100%
                     
I know the break lights work because when I use the clicker the taillights flash. I'm thinking the prior owner putting in an alarm system caused the problem. I have electrical tape galore under the dash, devastated wires all over. kind of why I'm thinking to replace the dash... ill let the professionals reinstall the remote start, car alarm.
zerokool is offline  
post #3 of 6 (permalink) Old 02-09-2017, 10:39 PM
Woober Goobers!

 
Ronbo's Avatar
 
Join Date: Mar 2005
Location: Tiny Pebble, AR
Posts: 42,788
Feedback: 44 / 100%
                     
It's the parking lights that flash when using the RKE FOB not the brake lights. So tail lights are OK.

Last edited by Ronbo; 02-09-2017 at 10:41 PM.
Ronbo is offline  
 
post #4 of 6 (permalink) Old 02-09-2017, 10:53 PM
Woober Goobers!

 
Ronbo's Avatar
 
Join Date: Mar 2005
Location: Tiny Pebble, AR
Posts: 42,788
Feedback: 44 / 100%
                     
All the items you describe as not working are on different circuits without any fuses related to each other. Could very well be the dash wiring is trashed.

The air bag and hazard signals share a common fuse/circuit.
Ronbo is offline  
post #5 of 6 (permalink) Old 02-09-2017, 11:51 PM Thread Starter
Intrepid Modder
 
zerokool's Avatar
 
Join Date: Jul 2010
Location: Park city, Ut.
Posts: 613
Feedback: 1 / 100%
                     
Quote:
Originally Posted by Ronbo View Post
All the items you describe as not working are on different circuits without any fuses related to each other. Could very well be the dash wiring is trashed.

The air bag and hazard signals share a common fuse/circuit.
the wiring is definitely suspect.when I click lock or unlock on the fob I see both sets of lights go off, parking and break lights. I have LED bulb in the breaks so it makes a weird blink one light than the other.

I also forgot to mention when I turn on the headlights the turn signals are both solid on.

so ronbo. you think I can just swap dashes and keep the bcm? will I run into issues with the skim module not being plugged in? I have the skim module, the special's BCM and PCM...



option 2. just replace pcm, bcm, dash and tow the car to a dealer for programming.
zerokool is offline  
post #6 of 6 (permalink) Old 02-10-2017, 07:12 PM
Woober Goobers!

 
Ronbo's Avatar
 
Join Date: Mar 2005
Location: Tiny Pebble, AR
Posts: 42,788
Feedback: 44 / 100%
                     
There isn't any difference between a Special BCM and the Standard 300M BCM.

Supposedly the BCM doesn't contain any of the Security Features regarding SKIM but I never got a definitive answer on that. The PCM will be the main component for Security Features. It'll poll the SKIM module to make sure all is good.

If you have a PCM in there now that's NOT SKIM enabled then the BCM swap supposedly won't do anything. However it seems your issue is more hacked wiring than a BCM problem. So any "Premium" BCM for your year car should work fine. All models 300M have a "Premium" BCM.

"Just Junk It LLC."
"Just Charge It"...shit I fried my ECM!
Member of the Sold SRT-8 Magnums of DI.net Club!
Perky Jerky for Everyone!!
Crazy Rons House of Mega Deals
Ronbo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Random Question

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome