2001 Chrysler T&C Radio/ATC/Heat Set display issue - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 19 (permalink) Old 09-18-2012, 12:59 PM Thread Starter
Intrepid Pro
 
Patel.748's Avatar
 
Join Date: Jul 2003
Location: Westerville, Ohio
Posts: 8,450
Feedback: 0 / 0%
                     
2001 Chrysler T&C Radio/ATC/Heat Set display issue

So I am fixing up some of the little issues that my wife's town and county has.

One of the issues that it has is the ATC/Heated Seat Display does not light up all parts of the display at night.

Here are a couple pictures to make sense of the situation.

Here is the day picture:




Here is the night shot with the backlights and you will notice where some parts are not lit.




So what the heck could be causing this? It's weird that both the heated seats control panel and atc display have the same issue. I have looked to see if they have the little bulbs that our LHs have on the back of the panel and it does not have the bulbs. Could it be a ground issue? Short in the wire?

Any thoughts/ideas would be helpful.

Thanks
Patel.748 is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 09-18-2012, 01:19 PM
I hit shit with sticks!


 
Daytrepper's Avatar
 
Join Date: Jan 2005
Location: Zebulon, NC
Posts: 34,520
Feedback: 20 / 100%
                     
Garage
Likely a few of the mini bulbs behind those panels are burned out.
Daytrepper is offline  
post #3 of 19 (permalink) Old 09-18-2012, 02:02 PM
1st Gen FTW - It's AutoMedic!

 
cdmccul's Avatar
 
Join Date: Jun 2008
Location: Garrison, ND
Posts: 15,412
Feedback: 18 / 100%
                     
Like the radios, do you have to maybe take the ATC apart to get to the bulbs?
cdmccul is offline  
post #4 of 19 (permalink) Old 09-18-2012, 02:18 PM Thread Starter
Intrepid Pro
 
Patel.748's Avatar
 
Join Date: Jul 2003
Location: Westerville, Ohio
Posts: 8,450
Feedback: 0 / 0%
                     
Quote:
Originally Posted by cdmccul View Post
Like the radios, do you have to maybe take the ATC apart to get to the bulbs?
I just took apart the heated seat/wiper panel apart and it looks like the bulbs are soldered/affixed to the board. To technical for me... looks like I am gonna have to buy a new unit... ugg
Patel.748 is offline  
post #5 of 19 (permalink) Old 09-18-2012, 02:20 PM
1st Gen FTW - It's AutoMedic!

 
cdmccul's Avatar
 
Join Date: Jun 2008
Location: Garrison, ND
Posts: 15,412
Feedback: 18 / 100%
                     
ugg is right... Maybe after you get a new one, you can find someone who wants to re-solder?
cdmccul is offline  
post #6 of 19 (permalink) Old 09-18-2012, 03:00 PM
Intrepid Pro
 
Squilliam's Avatar
 
Join Date: Nov 2008
Location: Greater Pittsburgh, PA
Posts: 15,038
Feedback: 2 / 100%
                     
That is by far, the coolest ATC head I've ever seen.
Squilliam is offline  
post #7 of 19 (permalink) Old 09-19-2012, 11:50 AM Thread Starter
Intrepid Pro
 
Patel.748's Avatar
 
Join Date: Jul 2003
Location: Westerville, Ohio
Posts: 8,450
Feedback: 0 / 0%
                     
I picked up a new Wiper/Heated seat switch for $15.

Anyone have any leads or would be willing to scope out the ATC head? The ones on eGhey are way too overpriced.

Part Number for ATC head: p05005004AF
Patel.748 is offline  
post #8 of 19 (permalink) Old 09-19-2012, 12:13 PM Thread Starter
Intrepid Pro
 
Patel.748's Avatar
 
Join Date: Jul 2003
Location: Westerville, Ohio
Posts: 8,450
Feedback: 0 / 0%
                     
Also doing some research it looks like it is also compatible with 2001-2002 Dodge Caravan's as well. Part Number: P05005004AG
Patel.748 is offline  
post #9 of 19 (permalink) Old 09-19-2012, 12:20 PM
get off my lawn


 
DrDodge's Avatar
 
Join Date: Jan 2006
Location: Smyrna , Tn
Posts: 15,448
Feedback: 6 / 100%
                     
to have it all out at the same time,, makes me think its something else,, I myself would take a good long look at some fuses,, radio continus power,, I think its a 20 amp, in the underhood box,
DrDodge is offline  
post #10 of 19 (permalink) Old 09-19-2012, 12:23 PM Thread Starter
Intrepid Pro
 
Patel.748's Avatar
 
Join Date: Jul 2003
Location: Westerville, Ohio
Posts: 8,450
Feedback: 0 / 0%
                     
Quote:
Originally Posted by DrDodge View Post
to have it all out at the same time,, makes me think its something else,, I myself would take a good long look at some fuses,, radio continus power,, I think its a 20 amp, in the underhood box,
hmmm...I'll go take a look here in a few and report back.
Patel.748 is offline  
post #11 of 19 (permalink) Old 09-19-2012, 12:25 PM
get off my lawn


 
DrDodge's Avatar
 
Join Date: Jan 2006
Location: Smyrna , Tn
Posts: 15,448
Feedback: 6 / 100%
                     
think about it,, its the same bulbs day or night
DrDodge is offline  
post #12 of 19 (permalink) Old 09-19-2012, 12:28 PM Thread Starter
Intrepid Pro
 
Patel.748's Avatar
 
Join Date: Jul 2003
Location: Westerville, Ohio
Posts: 8,450
Feedback: 0 / 0%
                     
Quote:
Originally Posted by DrDodge View Post
think about it,, its the same bulbs day or night
In the day they are not on. There is an activator LED that is not the same as the backlight lights. The backlights are out.

I guess if no fuses are out when I got check. The new unit that I am getting in will be the one that confirms if the unit is faulty or there is a short or ground issue.

Could the BCM cause this kind of issue? Cause the BCM has been tested by my Dad and it very seldom does take a dump and does not remember the electronic sliding doors and loses memory seat settings etc.
Patel.748 is offline  
post #13 of 19 (permalink) Old 09-19-2012, 12:30 PM
get off my lawn


 
DrDodge's Avatar
 
Join Date: Jan 2006
Location: Smyrna , Tn
Posts: 15,448
Feedback: 6 / 100%
                     
I dont think the bcm could,, me thinking the lights run seporate for it,, mind you,, i could be wrong,,
DrDodge is offline  
post #14 of 19 (permalink) Old 09-19-2012, 02:19 PM Thread Starter
Intrepid Pro
 
Patel.748's Avatar
 
Join Date: Jul 2003
Location: Westerville, Ohio
Posts: 8,450
Feedback: 0 / 0%
                     
All fuses are good.

Sent from my SGH-T959V using AutoGuide.Com Free App
Patel.748 is offline  
post #15 of 19 (permalink) Old 09-19-2012, 02:20 PM
get off my lawn


 
DrDodge's Avatar
 
Join Date: Jan 2006
Location: Smyrna , Tn
Posts: 15,448
Feedback: 6 / 100%
                     
ok,, well it was a shot,, sorry
DrDodge is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Random Question

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome