Just picked up my 04 special.. - Page 3 - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
post #31 of 43 (permalink) Old 03-26-2012, 03:55 PM Thread Starter
Intrepid Fan
 
Glmwpg's Avatar
 
Join Date: Nov 2006
Location: Winnipeg Canada
Posts: 124
Feedback: 0 / 0%
                     
Also - just placed an order for an FIPK and some AVS window shades & sunroof deflector
Glmwpg is offline  
Sponsored Links
Advertisement
 
post #32 of 43 (permalink) Old 03-26-2012, 03:57 PM
Intrepid Modder
 
Join Date: Apr 2008
Location: Chicago
Posts: 449
Feedback: 0 / 0%
                     
Oh man.. nice special. Must be nice to have a sunroof. lol
hypnotiq is offline  
post #33 of 43 (permalink) Old 03-26-2012, 05:34 PM
Intrepid Pro

 
paintballdude05's Avatar
 
Join Date: May 2007
Location: Sudbury, Ontario
Posts: 13,155
Feedback: 13 / 93%
                     
Quote:
Originally Posted by Glmwpg View Post
Also - just placed an order for an FIPK and some AVS window shades & sunroof deflector
The FIPK is a nice add on.

Sounds like the EL converter is on it's way out. I've had many Special clusters do this. One of the solutions is to buy an aftermarket Phase Morpher and install it in place of what's there.

Quote:
Originally Posted by hypnotiq View Post
Oh man.. nice special. Must be nice to have a sunroof. lol
I still can't believe somebody decided to delete the sunroof from a Special!
paintballdude05 is offline  
post #34 of 43 (permalink) Old 03-26-2012, 06:10 PM
Intrepid Modder
 
Join Date: Apr 2008
Location: Chicago
Posts: 449
Feedback: 0 / 0%
                     
Quote:
Originally Posted by paintballdude05 View Post
The FIPK is a nice add on.





I still can't believe somebody decided to delete the sunroof from a Special!
Hell yeah the FIPK is nice! Reminds me I need to clean mine. Yeah I can't believe it either... after the last meet and being the only special without a sunroof I have to have one.
hypnotiq is offline  
post #35 of 43 (permalink) Old 03-26-2012, 09:58 PM Thread Starter
Intrepid Fan
 
Glmwpg's Avatar
 
Join Date: Nov 2006
Location: Winnipeg Canada
Posts: 124
Feedback: 0 / 0%
                     
wow.. people actually delete sunroofs? :-o what a waste of time/energy/money unless it had to be done for some reason!

So I just spent the afternoon going through a bit of a checklist and getting things out of the intrepid, although I did spend some time with the M.

- All fluids looked good, but replaced all regardless. Fresh oil and coolant, power steering and brake fluid. Bled the brakes. Put in a new thermostat, burped the coolant system as best as I could and made sure its full. New oil filter. Cleaned and reinstalled the old air filter, it'll last until the FIPK arrives.

- Pulled that basic deck out and added my JVC with BT/USB/AUX, and used the mounting bracket for the deck from the intrepid which seals up a bit better than whatever it was that was in there before. Added the cubby pocket below the deck. Ran the hands-free mic to just beside the steering wheel & traction control... hope that's quiet enough for it. Took a can of compressed air and gave the interior a good dusting of all the cracks and crevices.. ATC is a lot quieter now - amazing how much dust builds up in there. I swear a small hamster popped out. Whoever had this stuff out previously out did a poor job putting it back together.. missing screws, fake carbon fiber panel sitting on top of the stereo bezel, the bottom panel below the steering wheel not snapped into place.. the stereo harness actually had some sort of jelly or lube all over it, which is pretty odd.

-No TMPS magnet by the spare (I'll probably just ignore this feature to be honest.. it's nice but not ~$250 nice).. Looks like I do have 4 installed sensors though. I also don't like to be harassed by the EVIC warning though :P

- I'll have to look into a phase converter. No real progress made on the dash lights yet - they seem to have a 50/50 chance of working.. can't really trend it, seems completely random. Sure is a nice strong glow when they do come on. I do know I only want to pull and replace the dash once, so I may wait a bit and see what other things I might do while it's out. Could I buy this and run it with the rear USB from my deck?

Proper photoshoot still coming,... going to get some nice shots downtown
Glmwpg is offline  
post #36 of 43 (permalink) Old 03-26-2012, 10:04 PM
Intrepid Pro

 
paintballdude05's Avatar
 
Join Date: May 2007
Location: Sudbury, Ontario
Posts: 13,155
Feedback: 13 / 93%
                     
What would you do with the thing you linked? Just for the converter? The think with that one is that you need one that is adjustable so that you can fine tune it to match the factory color. If my cluster was a different color than the rest of the interior lighting it would irritate me. When I had a Special cluster in my Intrepid it would behave just like yours so I got rid of it in favor of a black faced Concorde one.
paintballdude05 is offline  
post #37 of 43 (permalink) Old 03-26-2012, 10:11 PM Thread Starter
Intrepid Fan
 
Glmwpg's Avatar
 
Join Date: Nov 2006
Location: Winnipeg Canada
Posts: 124
Feedback: 0 / 0%
                     
Well basically it would run on whenever the deck is powered up. I'd run the glow wire behind the cluster as best I can. I hear you on the color difference, although my deck can fine tune color match with various RGB settings (I think 50 of each), the other lights would look out of place. Search continues for an adjustable one. Do you or anyone know if the (rear) USB port on a deck can be used in this manner? I'd just use the front USB for the BT plug/memory stick etc.

I guess one thing i'm not thinking about is current setup of the cluster - does the light come from the back and through the gauges or is it more "built in" to the gauge itself? I thought it was projected through. I'd know more if i'd already pulled one out.

Last edited by Glmwpg; 03-26-2012 at 10:35 PM.
Glmwpg is offline  
post #38 of 43 (permalink) Old 03-26-2012, 10:45 PM
Intrepid Pro

 
paintballdude05's Avatar
 
Join Date: May 2007
Location: Sudbury, Ontario
Posts: 13,155
Feedback: 13 / 93%
                     
paintballdude05 is offline  
post #39 of 43 (permalink) Old 03-27-2012, 01:05 AM Thread Starter
Intrepid Fan
 
Glmwpg's Avatar
 
Join Date: Nov 2006
Location: Winnipeg Canada
Posts: 124
Feedback: 0 / 0%
                     
hah.. damn.. just realized I didn't look into why the two power points don't work

that's probably a better suggestion than what I was working on
Glmwpg is offline  
post #40 of 43 (permalink) Old 03-27-2012, 12:18 PM
Intrepid Pro

 
paintballdude05's Avatar
 
Join Date: May 2007
Location: Sudbury, Ontario
Posts: 13,155
Feedback: 13 / 93%
                     
Could be a fuse, I'm leaning towards the connectors under the shifter bezel bing disconnected.
paintballdude05 is offline  
post #41 of 43 (permalink) Old 03-28-2012, 02:59 PM Thread Starter
Intrepid Fan
 
Glmwpg's Avatar
 
Join Date: Nov 2006
Location: Winnipeg Canada
Posts: 124
Feedback: 0 / 0%
                     
Yep quick fix there, reseated a bunch of fuses and both power points are now working

My next update will likely be the FIPK install or dash light progress.

Thanks folks
Glmwpg is offline  
post #42 of 43 (permalink) Old 12-23-2012, 07:29 PM
Intrepid Pro
 
Join Date: Aug 2005
Location: Arlington Texas
Posts: 2,818
Feedback: 1 / 100%
                     
No J1850 bus messages but everything else that needs the bus works? That sounds like the loss of the J1850/PCI bus pin on the cluster. You probably have one or more cold solder joints at the terminals.

Retouch these joints if they show even hairline cracks. A good TV shop can do it for you too.

Also, the J1850/PCI bus is present at the radio connections for the purpose of navigation and steering wheel controls. Make sure that if they used a harness or cut the wires that the J1850/PCI wire is insulated. It's purple and yellow if I recall correctly.

A failing battery can cause the BCM to absolutely go bonkers. Check your battery connections and the battery itself. Modern Chryslers have been known to freak out if the battery goes intermittent or gets internal high resistance....if it's weak but still starts, it may still be an issue as it filters the pulses from the alternator.

2004 300M Special...157K miles. Needs more mods!
hardwareguy is offline  
post #43 of 43 (permalink) Old 12-23-2012, 09:18 PM
Intrepid Pro
 
Join Date: Feb 2002
Location: Virginia, U.S.
Posts: 14,271
Feedback: 4 / 83%
                     
Quote:
Originally Posted by hardwareguy View Post
...A good TV shop can do it for you too...
I remember TV shops - from the 1960's!!
peva is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome