Help needed solving coolant leak problem - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 3 (permalink) Old 07-31-2012, 10:46 PM Thread Starter
Intrepid Newbie
 
Join Date: Dec 2011
Location: Florida
Posts: 26
Feedback: 0 / 0%
 
Help needed solving coolant leak problem

I am leaking a small amount of coolant where the upper radiator hose connects to the engine block. There is a male aluminum part that is bolted to the engine block that connects to the coolant hose and it appears coolant is leaking around this connection.

I am getting a rather frequent squealing sound in my fan belts, most likely caused when coolant drips onto the hose and changes the friction between the belt and sheaves.

I need to fix the coolant leak. I can replace the hose, although I believe this was done about a year ago when I had the water pump changed. I can replace the tension clamp with a worm drive clamp, or I can do more investigation.

Would appreciate any advice anyone has.
bigtrees is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-01-2012, 07:45 AM
Intrepid Pro
 
Join Date: Feb 2002
Location: Virginia, U.S.
Posts: 14,420
Feedback: 4 / 83%
                     
Which engine? I assume the 3.2 or 3.5.

The spring clamps are actually superior to the screw clamps for maintaining correct compression on the hoses to prevent leaks.

Just because the hose was replaced in the recent past is not reason not to replace it if it's leaking.

If it's not the hose or clamp, one possibility is an o-ring where the heater supply pipe connects to the underside of the lower intake manifold. They can go bad. Sometimes coolant from that will find its way to the back of the engine and drip down from there.


'98 LXi - Later Concorde gages (black w/ chrome rings)/'99 LX - LHS gages (white) - HIR bulbs

Last edited by peva; 08-01-2012 at 07:48 AM.
peva is offline  
post #3 of 3 (permalink) Old 08-03-2012, 11:31 PM
Intrepid Newbie
 
mralex714's Avatar
 
Join Date: Apr 2008
Location: Florida
Posts: 66
Feedback: 0 / 0%
                   
Quote:
Originally Posted by bigtrees View Post
I am leaking a small amount of coolant where the upper radiator hose connects to the engine block. There is a male aluminum part that is bolted to the engine block that connects to the coolant hose and it appears coolant is leaking around this connection.

I am getting a rather frequent squealing sound in my fan belts, most likely caused when coolant drips onto the hose and changes the friction between the belt and sheaves.

I need to fix the coolant leak. I can replace the hose, although I believe this was done about a year ago when I had the water pump changed. I can replace the tension clamp with a worm drive clamp, or I can do more investigation.

Would appreciate any advice anyone has.
I think you are talking about the bleed port have you tried to tighten it.
mralex714 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Random Question

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome