Problems:Solenoid/Pressure Switch Assembly Changeout [Archive] - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat

: Problems:Solenoid/Pressure Switch Assembly Changeout


amosbench
09-02-2004, 11:59 PM
Help!!! I got a 02 trep w/ 80,000 miles and I have a solenoid/pressure switch assembly that went to hell.(P1776). So I am changing the Input and Output speed sensors for good measure as well the solenoid assembly inside the the tranny above the valve body. I disconnected the shift cable and I now I can't drop the valve body out of the tranny case. There is a green female electrical connector with a red clip that I slid out to see if that was what was holding it in there but I still couldn't wrestle the damn connector off.
I was wondering if there is some special way of taking the connector off or if I am leaving something out of the process. Any expertise anyone can offer, will be greatly appreciated.

amosbench
09-03-2004, 12:11 AM
Oh Yeah it's a 2.7

D76G12
09-03-2004, 12:32 AM
2002 FSM ...

VALVE BODY
REMOVAL
NOTE: If valve body is being reconditioned or
replaced, it is necessary to perform the Quick Learn
Procedure. (Refer to 8 - ELECTRICAL/ELECTRONIC
CONTROL MODULES/POWERTRAIN CONTROL
MODULE - STANDARD PROCEDURE)
(1) Disconnect the TRS wiring connector. The solenoid wiring connector can remain attached to the case.
(2) Disconnect the shift cable from the shift lever (at the transaxle).
(3) Move the shift lever clockwise as far as it will go. This should be one position past the L position. Then remove the shift lever.
(4) Remove transaxle pan bolts (Fig. 408).
(5) Remove transaxle oil pan (Fig. 409). When reinstalling oil pan be sure that pan flange is clean and oil free. Apply a 1/8 inch bead of Mopar Silicone Sealer onto oil pan flange before installing.
(6) Remove oil filter from valve body (Fig. 410). It is held in place by two clips.
CAUTION: The 42LE transaxle oil filter is not interchangeable with the 41TE transaxle filter. Installation of a 41TE oil filter in a 42LE may cause transaxle damage.
(8) Carefully remove valve body assembly from transaxle (Fig. 412). (Fig. 415)
CAUTION: The overdrive and underdrive accumulators and springs may fall out when removing the valve body (Fig. 413) (Fig. 414) (Fig. 415).

As you can see there are several pics that go with this process. If possible, I suggest you download the FSM (http://dvms.dvusd.org/02lhe/) ...

D76G12
09-03-2004, 12:34 AM
SOLENOID/PRESSURE SWITCH ASSY
REMOVAL
NOTE: If the Solenoid/Pressure Switch Assembly is being replaced, the Quick Learn Procedure must be performed. (Refer to 8 - ELECTRICAL/ELECTRONIC
CONTROL MODULES/POWERTRAIN CONTROL MODULE - STANDARD PROCEDURE)
(1) Raise vehicle on hoist.
(2) Remove valve body assembly from transaxle. (Refer to 21 - TRANSMISSION/TRANSAXLE/AUTOMATIC - 42LE/VALVE BODY - REMOVAL)
(3) Remove Solenoid/Pressure Switch Assembly retaining screws from solenoid (Fig. 380).
(4) Remove Solenoid/Pressure Switch Assembly and screen from valve body (Fig. 381).

amosbench
09-03-2004, 12:45 AM
Learn the hard way I guess. I didn't turn the shift lever clockwise as far as it will go. I studied the FSM at work but at home (I live in rural Idaho) I got dial-up so getting the SM is impossible. I am assuming that the shift lever must release the valve body from the green electrical connector in some way. I will hafta try it in the morning though. Thank the heavens for you guys and di.net!!

Smoke
09-03-2004, 01:02 AM
Problems:Solenoid/Pressure Switch Assembly Changeout

--------------------------------------------------------------------------------

Help!!! I got a 02 trep w/ 80,000 miles and I have a solenoid/pressure switch assembly that went to hell.(P1776). So I am changing the Input and Output speed sensors


How did you know it was your solenoid/pressure switch assembly that went to hell? I also have an 02 Trep and Just curious how and what you did to find out this was your problem. Was it Just Codes etc....?

amosbench
09-04-2004, 12:47 AM
It all started with my upper tranny line to my radiator springing a leak and my dumb ass not checking the fluid until it went into limp mode. Anyway, I drove it home and changed the leaking line and filled it up with +4 the next day. Thinking I fixed the problem. I reset the check engine light by disconnecting the battery. But the light came back on in a few miles so I went and rented a code reader from Schucks. It gave me the P0700 code and P1776 code. The 700 code is something about my EATX. The 1776 code is pretty specific and it states in the service manual that the Low/Reverse valve is stuck in the such n such position don't quite remember. But I went down to the dealership and a cool mechanic told me what it usually causes that code. Anyway, he told me to check the relay switch to the tranny and if that it was okay that it was probably the solenoid/pressure switch assembly which controls the L/R valve. I burned up the other solenoid assembly when I ran it low on fluid, I think. So I figure I might as well do a minor rebuild on what i could with the tranny. Upper and Lower tranny lines to the radiator($8 each), Solenoid/Pressure Switch Assembly($178), Input Speed Sensor ($23), Output Speed Sensor($23) and more tranny fluid, of course, all from the dealership.
Started the changeout last night and finished this morning with the help of the people of di.net. Started the car and so far is running better than before.

D76G12
09-04-2004, 01:19 AM
But the light came back on in a few miles so I went and rented a code reader from Schucks. You DO realize that our cars will give you the codes for free ...??? Even my '89 LeBaron could do it - but not as easily as the 2G Treps ...

http://dodgeintrepid.net/forums/showthread.php?t=9490

amosbench
09-05-2004, 08:59 PM
Yes, I realize that you can get the codes with the three ignition turn on procedure. But when I did that I only got the P0700 code, I had to get the code reader to get the P1776 code.

eileen
10-13-2004, 12:51 AM
hi there............I need some help please, i have a 02 intrepid SE with 50,000 miles, my problem is the following
the first 20 minutes i dont have any problems driving, after the engine or the trani is warmmy problem will begin,when i stop my intrepid remain idle for few seconds and then go back to normal or if i go over 45 miles will shift to second gear and will not return to normal, i need to shut off the engine and back on again to go back to normal, any sugestions about this problem are very welcome ( i dont have anymore warranty on this car)

L.O.K.O.
09-09-2008, 10:12 PM
hi there............I need some help please, i have a 02 intrepid SE with 50,000 miles, my problem is the following
the first 20 minutes i dont have any problems driving, after the engine or the trani is warmmy problem will begin,when i stop my intrepid remain idle for few seconds and then go back to normal or if i go over 45 miles will shift to second gear and will not return to normal, i need to shut off the engine and back on again to go back to normal, any sugestions about this problem are very welcome ( i dont have anymore warranty on this car)

I was getting the SAME exact code(s) and my car was doing the
SAME exact thing after 45mph or so. I would come to stoplight,
and the car would jerk a lil, then be stuck in 2nd gear until i turned off
the car.
***please do this first***

its the easiest, cheapest thing to do!
__replace your intake & outake sensors!
__they cost about $13 each!

***IT FIXED MY PROBLEM!!***

to the thread starter, make sure you've gotten that leak fixed.
mine was leaking through the radiator and i believe thats
what got me in this runt in the 1st place. it would leak transmission fluid
so i would be buying more +4 fluid like every 2 weeks!
i was lazy and didn't feel like paying to FIX the problem, so
i kept putting band-aids on it. lol

yiranhu
09-10-2008, 12:17 PM
It all started with my upper tranny line to my radiator springing a leak and my dumb ass not checking the fluid until it went into limp mode. Anyway, I drove it home and changed the leaking line and filled it up with +4 the next day. Thinking I fixed the problem. I reset the check engine light by disconnecting the battery. But the light came back on in a few miles so I went and rented a code reader from Schucks. It gave me the P0700 code and P1776 code. The 700 code is something about my EATX. The 1776 code is pretty specific and it states in the service manual that the Low/Reverse valve is stuck in the such n such position don't quite remember. But I went down to the dealership and a cool mechanic told me what it usually causes that code. Anyway, he told me to check the relay switch to the tranny and if that it was okay that it was probably the solenoid/pressure switch assembly which controls the L/R valve. I burned up the other solenoid assembly when I ran it low on fluid, I think. So I figure I might as well do a minor rebuild on what i could with the tranny. Upper and Lower tranny lines to the radiator($8 each), Solenoid/Pressure Switch Assembly($178), Input Speed Sensor ($23), Output Speed Sensor($23) and more tranny fluid, of course, all from the dealership.
Started the changeout last night and finished this morning with the help of the people of di.net. Started the car and so far is running better than before.

The funny thing is a "low" mileage used tranny from a 2.7 only costs 70 bucks around here. Ultra low mileage is around 150 to 200... Just some food for thought...