Engine Turn Over Issue [Archive] - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat

: Engine Turn Over Issue


Eaglechef86
10-16-2006, 04:20 PM
Hey, I am hoping that one of yall can help me with this problem. I think somethin is drainin my battery. In the mornin when I get up to go out I try to start my car it wont turn over. theres power to the accessories and all I hear is the starter clicking continuously when I have the key turned to start. Ive had the altenator checked while it was running its putting out 14.47 volts so im at a loss for anything else. Any other ideas would be great if you can help. Thanks

mhzjunkie
10-16-2006, 05:13 PM
It's the contacts inside your starter, more than likely. Take it to a trusted starter/alternator shop and have the contacts replaced.

newfielaw
10-16-2006, 06:15 PM
is it just when the car is cold or do it happend all the time
mine was the same way and the batt was no good after i had the starter replaced i found it out

chevyjr73
10-16-2006, 06:40 PM
sounds like a bad battery to me, have it load tested.

mhzjunkie
10-16-2006, 07:37 PM
After rereading what you wrote, it appears that newfielaw and chevyjr73, may be right. If you turn your key switch to the start position, and it clicks once, then you release it and try again, and it clicks again, then it's the contacts in the starter.

If you turn the key to the start position and hold it there and it clicks continuously, then it's what newfielaw and chevyjr73 mentioned. I will add that it could also be your cables needs cleaning.