Unusual Electrical Problem - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 (permalink) Old 10-12-2014, 09:58 PM Thread Starter
Intrepid Newbie
 
Join Date: Oct 2014
Location: Earth
Posts: 2
Feedback: 0 / 0%
 
Unusual Electrical Problem

Not sure I'm posting correctly - first time

98 Intrepid 3.2L
Vehicle sat with bad starter and dead battery for appx 30 months.
Changed starter and vehicle starts and runs.
No trouble codes from ECM

PROBLEM:
Key is stuck in ignition switch
Instrument cluster is dead, no tail lights, no parking lights. Headlights and turn signals are functioning.
With headlights ON, engaging high beams and holding high beam switch fully to the rear, the instrument panel engages and operates. Gauges only work when the high beams are being turned ON and the switch held and NOT when turning high beams OFF.

Need HELP
Diego is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-12-2014, 10:49 PM
Intrepid Fan
 
krazybob738's Avatar
 
Join Date: Feb 2012
Location: chicago
Posts: 224
Feedback: 0 / 0%
 
good evening I have seen a problem similar to this is a ford f250 after a few hours of chasing this problem I found out that the turn signal switch was broken that fixed all the lighting issues as far as the key issue try moving the shift lever past park a little if that doesn't work try removing the center counsel and inspecting to shift linkage there maybe something is jammed or loose ( I am assuming your key isn't bent)
krazybob738 is offline  
post #3 of 4 (permalink) Old 10-24-2014, 09:55 PM Thread Starter
Intrepid Newbie
 
Join Date: Oct 2014
Location: Earth
Posts: 2
Feedback: 0 / 0%
 
Thanx. I think youre right and I ordered an aftermarket column switch. I discovered that the horn and radio are also affected in the same manner as the instrument cluster so its some type of common fault. Fas as the key, the lock seems to have some slack in the cylider. Unknown if its normal. The key may be bent. My 17 year old nephew had been driving it and cant give a clear answer on how the key got stuck or what he did to try to revmove it. Also, difficult to tell with the key stuck, but I think its a SKIM. Its the black triangular head, but it appears to have a compartment of some sort. I guess it should work to epoxy the transponder to the inside of the colunm housing and use a common replacement key?
Diego is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 10-24-2014, 10:04 PM
Intrepid Modder
 
Firemnted's Avatar
 
Join Date: Oct 2012
Location: Wisconsin
Posts: 529
Feedback: 0 / 0%
                     
Check your fuses with a meter! I had similar problems after my accident and had a few blown fuses! Some under the hood! Also remove and clean the grounds at the fuse box under the hood!
Firemnted is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome