Window squealing...2002R/T - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 13 (permalink) Old 04-19-2008, 02:53 PM Thread Starter
Intrepid Pro
 
intrepid.luvah's Avatar
 
Join Date: Oct 2006
Location: Montreal, Quebec
Posts: 2,079
Feedback: 1 / 67%
                     
Window squealing...2002R/T

Hi guys I had my 2002 R/T for a while now, and the drivers side started developing this squealing when I raise it. It started to get louder and louder and is very annoying... I also believe this is a common problem since all 3 treps we have do this noise...It also seems to get even louder when it's hot outside... Any ideas on a easy/cheap fix ?
intrepid.luvah is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 04-19-2008, 03:22 PM
Intrepid Pro
 
dabirdzR/T's Avatar
 
Join Date: Jul 2002
Location: Myerstown, PA.
Posts: 6,788
Feedback: 7 / 100%
                     
ahh, grease the track, maybe its causin undo stress in the motor? maybe the gears are stripped, cause the high pitched noise?

pull the panel off and poke around, see if you can pinpoint the issue?
dabirdzR/T is offline  
post #3 of 13 (permalink) Old 04-19-2008, 03:40 PM Thread Starter
Intrepid Pro
 
intrepid.luvah's Avatar
 
Join Date: Oct 2006
Location: Montreal, Quebec
Posts: 2,079
Feedback: 1 / 67%
                     
It sounds like the glass rubbing against rubber.
intrepid.luvah is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 04-19-2008, 04:59 PM
 
Join Date: Jan 2007
Posts: 107
Feedback: 0 / 0%
 
Put some grease on the rails. Almost all treps, 300m and lhs cars have that issue.
omnibus is offline  
post #5 of 13 (permalink) Old 04-19-2008, 05:36 PM Thread Starter
Intrepid Pro
 
intrepid.luvah's Avatar
 
Join Date: Oct 2006
Location: Montreal, Quebec
Posts: 2,079
Feedback: 1 / 67%
                     
I did a couple of times, I'll try again and let u know. Thanks!
intrepid.luvah is offline  
post #6 of 13 (permalink) Old 04-19-2008, 07:23 PM Thread Starter
Intrepid Pro
 
intrepid.luvah's Avatar
 
Join Date: Oct 2006
Location: Montreal, Quebec
Posts: 2,079
Feedback: 1 / 67%
                     
Did it again and used tons of oil, got a little better but its still there. When It's half open and I push down on it it will make the noise.
intrepid.luvah is offline  
post #7 of 13 (permalink) Old 04-20-2008, 01:35 AM
Intrepid Pro
 
linuxglobal's Avatar
 
Join Date: Sep 2005
Location: Mississauga-Toronto, Ontario
Posts: 2,840
Feedback: 5 / 100%
                     
actually, all power windows have these issues.

Use a good silicone based lubricant.

A friends G35 had a similar problem where the window actually tilted and because the car uses a messed up cabin pressure system where the windows have a position sensor in the rail it stopped moving thinking it reached the top halfway or wherever. It also makes ur car use the power window motor every time you get in and out of the car, real waste of energy and window mechanism. Ud have to pull it up manually, thank God for no window frame.

Be sure to also check that the mechanism (not sure what it looks like on our cars) but most are like scissors, check the joint and see that its not bending at the center, if it is, it will soon being to slow down and eventually get stuck.

Check and then order new parts off ebay, i never use my power windows but i get this odd sound right when its up to the top. Like fully up, and then i let go of the switch, and its like a plastic flexing or something, but the motor isnt moving. Im thinking the window is just relieving pressure from being forced into the frame.

Its been doing that since about 1 week that i got it new and the dealer said some bs about the window "LOCKING" which i doubt. Its prob the frame + window contact.

Anyways maybe someone can elaborate on that, all my windows make that noise but not as loud as the driver and not for such a long period (1-2 sec) either.

linuxglobal is offline  
post #8 of 13 (permalink) Old 05-01-2008, 11:12 PM
Intrepid Modder
 
spence340's Avatar
 
Join Date: Nov 2007
Location: needham, MA 02494
Posts: 343
Feedback: 2 / 100%
             
The drivers window on my newest Intrepid and my last one sound really tight as they reach the top. Sounds almost too tight like it might be straining the motor.
spence340 is offline  
post #9 of 13 (permalink) Old 05-01-2008, 11:34 PM
K9
Intrepid Pro
 
K9's Avatar
 
Join Date: Mar 2007
Location: Hanover Twp. Pennsylvania
Posts: 1,206
Feedback: 2 / 100%
                     
Mine does a little squeel too. It only does it in the summer. I find that if I clean the windows good it seems to quiet down some...
K9 is offline  
post #10 of 13 (permalink) Old 05-01-2008, 11:40 PM
Intrepid Pro
 
linuxglobal's Avatar
 
Join Date: Sep 2005
Location: Mississauga-Toronto, Ontario
Posts: 2,840
Feedback: 5 / 100%
                     
silicone spray!!!

linuxglobal is offline  
post #11 of 13 (permalink) Old 05-02-2008, 12:34 AM
Intrepid Pro
 
MegaTrep's Avatar
 
Join Date: May 2007
Location: M'waukee, WI
Posts: 2,792
Feedback: 2 / 100%
                     
I used spray teflon grease on one and spray white lithium grease on another, and they are both quiet.
MegaTrep is offline  
post #12 of 13 (permalink) Old 05-03-2008, 03:30 PM
Intrepid Fan
 
Euro-poweR's Avatar
 
Join Date: Jul 2007
Location: Alamogordo, NM - USA
Posts: 193
Feedback: 0 / 0%
   
my drivers side window has been doing that ever since I got the car, another issue though, is it normal that the windows roll up rediculusly slow when you try to close all 4 at once?.... even when I just close both back windows it takes for ever and a half

Euro
Euro-poweR is offline  
post #13 of 13 (permalink) Old 05-03-2008, 05:01 PM
Intrepid Pro
 
linuxglobal's Avatar
 
Join Date: Sep 2005
Location: Mississauga-Toronto, Ontario
Posts: 2,840
Feedback: 5 / 100%
                     
well did you get ur car used?
I got mine new and it didnt do it.

Its normal for them to take longer when you are trying to roll up all 4. Our cars have very basic power management systems, prob because of all that 18 ga wiring.
linuxglobal is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome