Limp Mode Code 66 Dead Speedo PRND2L All Lit - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 (permalink) Old 04-22-2008, 12:18 AM Thread Starter
 
Join Date: Apr 2008
Posts: 7
Feedback: 0 / 0%
 
Limp Mode Code 66 Dead Speedo PRND2L All Lit

Was going to put this in the LHS section,as its a 1997 LHS,but after doing a little web browsing,it seems this dreaded code can afflict many chryslers....

Car only has 140,00 KM on it,immaculate shape,well kept and maintained.

Its in limp mode,and giving me code 66- No CCD bus messages PCM did not receive messages from the CCD bus.

or

No body CCD messages PCM did not receive CCD bus messages from the body control module.

or

No EATX CCD messages PCM did not receive CCD bus messages from the transmission control module.

Wow....where to start..Brother is a mechanic at a chrysler dealer,so far he's checked that the TCM is getting power,and it is,checked the relays in the fuse box under the hood,they are working fine...checked the wiring harness in the drivers side corner by rad for breaks in wiring... ..read another post where a guy hard wired the 2 tranny connectors behind the airbox,against the firewall,and everything was fine,haven't tried that yet,but popped them apart and cleaned them real good,still the same....cleaned reconnected wiring to the tranny itself...still the same.....swapped a gauge cluster out for a wrecker one...still the same...

Haven't tried swapping the TCM yet,bro says part #'s have to match perfectly from one thats in there already......is that true,or can I pull one from a concord or intrepid as long as its a 3.5 non auto-stick car...???...Even if its just for troubleshooting...??...as the local wreckers didn't have one exactly the same....

Possibly the BCM...???...Anyone ever have one of those actually go bad...???... are they all the same...???

And what is CCD Bus Messages...???...What is the CCD Bus...??

Hopefully you guys can help,this is driving me nuts,hate to junk a beautiful shape platinum full load LHS....

Thanks...
sickofit is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-25-2011, 09:15 PM
Intrepid Pro
 
94_Concorde's Avatar
 
Join Date: May 2003
Location: Somerset, Ohio
Posts: 1,506
Feedback: 1 / 100%
                     
I know this is an old thread, but my 94 Concorde just started doing the same thing. I have a 97 Concorde BCM (for alarm) and TCM (for autostick) in my car.

Did you ever find a solution to your issue?
94_Concorde is offline  
post #3 of 4 (permalink) Old 08-06-2011, 12:10 PM
Intrepid Newbie
 
Join Date: Apr 2010
Location: Kakabeka Falls On.
Posts: 26
Feedback: 0 / 0%
 
I had the exact same problem with my 94 trep and it turned out to be a corroded wire in the harness. You have to look at the harness under the battery tray where the tcm wiring joins the main harness,pull the loom off and look for where the red wires with white stripes from the tcm join with the wires for the bcm and ecm.I found 1 wire that was bared just a bit,when i cut it it was obvious from the corrosion that there was no connection. I spliced in a short piece and voila everything worked again.I was surprised that it was corroded because the car was rust free and didnt have too many miles on it.
wavemaker is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 08-08-2011, 10:08 PM
Intrepid Pro
 
94_Concorde's Avatar
 
Join Date: May 2003
Location: Somerset, Ohio
Posts: 1,506
Feedback: 1 / 100%
                     
Wow, great! Thanks for the info, I will have to check that. I installed AutoStick in my car a couple of years ago, maybe that has something to do with my problems.
94_Concorde is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome