Sad/Funny/Annoying/Infuriating. - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
post #1 of 4 (permalink) Old 06-21-2008, 04:38 PM Thread Starter
Intrepid Newbie
 
Crrusher's Avatar
 
Join Date: Nov 2007
Location: Guam
Posts: 12
Feedback: 0 / 0%
 
Sad/Funny/Annoying/Infuriating.

OK so yesterday I get ready to go home from work and my car won't start so I am like oh well the battery died big deal, so i get a jump i drive to a place to eat and i come out and the car won't start again, so i get someone to jump it and i figure i will drive it around this time and give it a chance to charge up the battery and my battery light comes on which it has never done before, and a few miles later the ABS and track off lights come on and it does that weird jump thing so i am thinking it is the alternator y else would it be acting all weird. it is friday like 730 so all the mechanic places are closed so i am like **** i don't want to be bugging people everytime i need to start my car, so i go over to walmart and get one of the portable car jumpers but the damn thing didn't come with enough juice to jump my car, so i call a friend and he comes over and jumps me, so at this point i am pissed and don;t want to have to buy a new alternator, so next morning i jump it myself and take it to autozone to get it tested to see if it is the battery or the alternator, they tell me the battery so i am relieved because that just saved me like $300 so i drive it over to the local auto hobby shop and the dude tells me he will take it out and put the new one in for $30 plus stall fees so i tell him ok since i had never taken the battery out myself before. so he takes the battery out and i get a friend to drive me over to walmart to get the new battery since the one i had was still under the 2 year warranty and walmart no longer will change out the batteries in intrepids. so the walmart guy tests it and says the battery is good and i argue with him for a bit and whatever but he was the head guy from the TLE so there wasn;t shit i could do, so i take it to autozone to have them test the actual battery instead of the hookups on top of the engine and they also tell me it is good. and the dude looks at the battery and says the terminals are kinda dirty and that that may be the problem, so i take the battery back to the auto hobby shop and tell them and they clean off the terminals on the battery and the battery connectors and put it back in and it works fine. so pretty much i paid them $36 to clean my terminals, pretty gay then add in the $50 for the portable jumper.


and i stil have to get the timing belt and stuff taken care of next week
Crrusher is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-21-2008, 07:38 PM
Intrepid Pro
 
linuxglobal's Avatar
 
Join Date: Sep 2005
Location: Mississauga-Toronto, Ontario
Posts: 2,840
Feedback: 5 / 100%
                     
so its not working now ?? still needs to get jumped all the time.

I mean logically a battery can be good as in able to hold a full charge but if there is any issue with the charging loop in the alternator you will still have issues and the battery wont fully charge. So there has to be a problem somewhere with a shop that is not giving you the correct answer.

Not sure why the track off light would come on, thats an odd one.

Try measuring the voltage at the battery with the engine on/off.
The voltage should be higher with the engine on, around 13.5-14v and lower with the engine off.

PS batteries charge relatively quickly to a level where they can restart the car again. My friends 540i always dies cuz it has like 200k km and with a bad battery on top of it he needs to carry a booster all the time. But if he leaves the car running for about 10 minutes in the driveway it will be enough to get it going again.

I would get this issue fixed before the timing belt because ure dropping a nice sum of money in a car that isnt that reliable just yet. Perhaps try another shop and dont tell them anything from the other places, just tell them your car is acting funny and needs to be boosted, ask them what needs to be replaced.

CM

linuxglobal is offline  
post #3 of 4 (permalink) Old 06-21-2008, 07:44 PM Thread Starter
Intrepid Newbie
 
Crrusher's Avatar
 
Join Date: Nov 2007
Location: Guam
Posts: 12
Feedback: 0 / 0%
 
sry bro i guess u misunderstood part of it, my car works fine now, the battery just wasn;t connecting right because f corrosion and stuff on the terminals
Crrusher is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-21-2008, 07:52 PM
Intrepid Pro
 
linuxglobal's Avatar
 
Join Date: Sep 2005
Location: Mississauga-Toronto, Ontario
Posts: 2,840
Feedback: 5 / 100%
                     
well ur last sentence is kind of misleading. You make it seem that you have all of these issues and more stuff coming up.

I guess its good to hear its all good now.

CM
linuxglobal is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome