2002 dodge intrepid es red oil light flashes idle just recently started going out - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 5 (permalink) Old 12-06-2014, 09:59 AM Thread Starter
Intrepid Newbie
 
Join Date: Dec 2014
Location: Cleveland
Posts: 4
Feedback: 0 / 0%
 
2002 dodge intrepid es red oil light flashes idle just recently started going out

I've notice for a month or so that my red oil light flashes whenever at idle. So I changed the oil after I was finished I had my brother changed the oil filter(starting to think he didn't do it) I notice the accerlaration got better. The next day after driving I notice when the temp got between hot and cold the red oil light flashes.. One week later it started going out when I stop to turn or at a stop light. I can turn it of wait half an hour then get it back home...this only happens when the tempture gets in the middle of hot and cold could this be the sensor or oil pump or perhaps my bro didn't change the filter.....could a oil filter cause this
duecefromcleveland is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-13-2014, 11:31 AM
Intrepid Newbie
 
DIYer's Avatar
 
Join Date: Nov 2014
Location: Alberta Canada
Posts: 32
Feedback: 0 / 0%
 
I think that would be sensor issue. The best thing you could do is check the level your self. I'm pretty sure the oil filter wouldn't do anything if it was changed or not. You could actually leave the filter in for a couple oil changes according to the manual. As your car heats up the oil gets more runny or thin which could be why it messes with the oil sensor. Why didn't you just change the filter yourself as you were changing the oil?
DIYer is offline  
post #3 of 5 (permalink) Old 12-13-2014, 09:34 PM Thread Starter
Intrepid Newbie
 
Join Date: Dec 2014
Location: Cleveland
Posts: 4
Feedback: 0 / 0%
 
Something came up while I was draining the oil my brother said he did it for me as for the car now until I get paid I've been driving it and whenever I stop at lights or idle I put it in neutral and it actually haven't cut out on me since I made this post
duecefromcleveland is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 12-14-2014, 12:38 PM
Intrepid Modder
 
Join Date: Jan 2011
Location: Moved on
Posts: 738
Feedback: 0 / 0%
                     
Replace the sensor, but make sure that you use OEM only.
Aftermarket sensors do not work right on our cars.
BiliTheAxe is offline  
post #5 of 5 (permalink) Old 06-05-2015, 03:42 PM
Intrepid Newbie
 
Join Date: Jun 2015
Location: Mexico
Posts: 1
Feedback: 0 / 0%
 
I had the same problem on my intrepid 1998,change the oil to 10-40w
harim is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome