2004 Intrepid 3.5 A HANDFUL of problems & codes. Plz Help - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
post #1 of 3 (permalink) Old 01-21-2015, 04:46 PM Thread Starter
Intrepid Newbie
 
Join Date: Jan 2015
Location: Indianapolis, IN
Posts: 6
Feedback: 0 / 0%
 
2004 Intrepid 3.5 A HANDFUL of problems & codes. Plz Help

So I bought my car last week (police package) & have several problems, a trunk full of parts/supplies to put on/in already, and need advice. 2 Major issues, overheating and "sputtering"/ trying to die on me.

I hooked it up to a scanner & it pulled several codes (mainly dealing w/emissions & sensors).
I bought a cam sensor (due to P0340 code) but don't want to put it on until I get some feedback.
I test drove it for 45 min prior to purchase. Has 123,xxx miles, performance was excellent until the next morning when I was going to work. It sputtered, jerked (hard&rough), acted like it was running out of gas but I'd just filled the tank. First thing I thought of was the fuel pump, but hoping it's something easier. *It doesn't do this every time I drive. Sometimes it runs perfectly. (After using a bottle of fuel injection cleaner it ran smoothly... for one day.) Other times I can put the gas pedal almost to the floor with little to no result.
P0132, P0058, P0152, P0108, P0300, P0038
Any feedback would be appreciated.

As for the overheating it didn't do it until last night. My daughter and I were driving home when we encountered a bit of road rage which turned into us having to outrun a lunatic @95mph for a few miles. (Yes, a bit extreme but this idiot was trying to ram us from the side so I had to get away.) As soon as we pulled into the driveway smoke started coming out from under the hood. I popped it & saw antifreeze all over the inside & a huge pool under the car. This morning I filled the overflow back up and did not see any new puddles, but when driving the temp guage rises quickly to the 1/2way point between hot& cold. It is worse on inner city streets than highway. Obviously the "high speed chase" has something to do with the overheating... maybe I blew the thermostat?

Last edited by moontiger; 01-21-2015 at 05:20 PM.
moontiger is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-21-2015, 09:05 PM
Intrepid Newbie
 
tf34mech's Avatar
 
Join Date: Jan 2013
Location: SW Michigan
Posts: 83
Feedback: 0 / 0%
 
Most of the codes involve the O2 sensor check to see if the wires from the sensor have come in contact with the exhaust and are worn through the insulation. Also check the grounds for the PCM we've had a lot of temperature and humidity changes here in the Midwest recently that tends to bring out any weaknesses in electrical systems.

As far as the over heating it's possible that you lost enough coolant to leave an air pocket or two in the cooling system. There is a bleed valve on the top of the lower intake manifold that needs to be opened while the engine is warming up.
tf34mech is offline  
post #3 of 3 (permalink) Old 01-21-2015, 09:12 PM Thread Starter
Intrepid Newbie
 
Join Date: Jan 2015
Location: Indianapolis, IN
Posts: 6
Feedback: 0 / 0%
 
Quote:
Originally Posted by tf34mech View Post
Most of the codes involve the O2 sensor check to see if the wires from the sensor have come in contact with the exhaust and are worn through the insulation. Also check the grounds for the PCM we've had a lot of temperature and humidity changes here in the Midwest recently that tends to bring out any weaknesses in electrical systems.

As far as the over heating it's possible that you lost enough coolant to leave an air pocket or two in the cooling system. There is a bleed valve on the top of the lower intake manifold that needs to be opened while the engine is warming up.

* Thanks... That's very helpful. At least now I have a little direction as far as where to look first :-)
Yes, I had them print the codes up for me (bank 1&2 sensor 1&2) & cam position sensor(already bought the latter, just havent put it on yet, but guessing it's the #1 prob w/performance). I bought the Chiltons Manual within hours of buying the car because I know how my luck runs,lol!
moontiger is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome