Has anyone purchased a warranty? - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 9 (permalink) Old 02-11-2009, 11:21 AM Thread Starter
Intrepid Newbie
 
Join Date: Jul 2001
Location: NH
Posts: 46
Feedback: 0 / 0%
 
Question Has anyone purchased a warranty?

I've been getting alot of emails lately for companies offering warranties on cars up to 10 years old. The packages run between $800-$1200.

My Trep is reaching 8 years old and 175k miles.
I'm pretty sure my tranny is on its last legs and I know from experience that these are not cheap to replace. I paid about $2200 for a replacement tranny for my Explorer several years ago.

Has anyone purchased a warranty for their older Intrepid before?
If so, do you have any recommendations?

Thanks!
Xanman is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 02-11-2009, 12:50 PM
Intrepid Fan
 
Join Date: Mar 2008
Location: VT
Posts: 234
Feedback: 0 / 0%
                     
Quote:
Originally Posted by Xanman View Post
I've been getting alot of emails lately for companies offering warranties on cars up to 10 years old. The packages run between $800-$1200.

My Trep is reaching 8 years old and 175k miles.
I'm pretty sure my tranny is on its last legs and I know from experience that these are not cheap to replace. I paid about $2200 for a replacement tranny for my Explorer several years ago.

Has anyone purchased a warranty for their older Intrepid before?
If so, do you have any recommendations?

Thanks!
I dont know about those warranties but I just had a tranny w/17-18k put in for my brother. Cost a little under 600 including labor.
Project4.0 is offline  
post #3 of 9 (permalink) Old 02-11-2009, 01:11 PM Thread Starter
Intrepid Newbie
 
Join Date: Jul 2001
Location: NH
Posts: 46
Feedback: 0 / 0%
 
$600!?!! Was this through the Dodge dealer or an independent repair shop?

Did you find the tranny yourself at a junk yard or something?
Xanman is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 02-11-2009, 02:41 PM
Intrepid Pro
 
TCPMeta's Avatar
 
Join Date: Aug 2006
Location: Jacksonville, FL
Posts: 2,935
Feedback: 0 / 0%
                     
I had a warranty from a company called Continental Warranty. When they were bugging me to get a account I told them straight up I prefer to do my own tune ups and also toss on aftermarket parts. They didn't care but I never had to use them. Funny thing was after I got rid of the warranty my engine blew. Yet for all I know if I did keep them and used them to have my car fixed when I blew the motor and with my luck I doubt they would do anything since I had after market parts like the K&N cold air and flowmaster exhaust. I take that back, I did use them when I had the car repainted. Some one keyed up the driver side door and fender. I only had to pay a 200 deductible a month later.

If your not car savy and haven't tossed on aftermarket parts I would get a quote from Continental Warranty. I think mine was 30 a month and covered everything.

Last edited by TCPMeta; 02-11-2009 at 02:44 PM.
TCPMeta is offline  
post #5 of 9 (permalink) Old 02-11-2009, 06:57 PM
Intrepid Pro
 
jedgxe's Avatar
 
Join Date: Mar 2004
Location: Wisconsin
Posts: 1,439
Feedback: 0 / 0%
                     
Be very careful. Ask lots of specific questions. Last year My daughter had her heart set on buying a '97 Grand Am. We test drove it and everything seemed fine. We bought it and paid an additional $800 for a warranty. Three months later I noticed a slight rod knock, a few days later the radiator blew out, loosing a lot of coolant. She immediately pulled over and had it towed to her mechanic. A very trustworthy mechanic in my opinion. He replaced the radiator, but when he started it up , the rod knock was extremely nasty. The mechanic called the warranty co. to see if they would pay for repairs. The warranty co said the only way they would pay for it is if something was actualy broken. As most people know , with a rod knock , nothing is actualy broken, just worn so bad that ya wouldn't want to drive it anymore or sure as shit wind up being stranded with a dead engine somewhere in the middle of hell. So I wound up paying for a Jasper re-manufactured engine with no help from the useless fricken warranty.

2003 Intrepid SXT 51,000 miles 1-10-06

'94 3.3 Intrepid owned since May '94 182,000 miles has been traded in for the above.
jedgxe is offline  
post #6 of 9 (permalink) Old 02-11-2009, 08:34 PM
Intrepid Newbie
 
Join Date: Dec 2008
Location: Western WI
Posts: 95
Feedback: 2 / 100%
 
You should've thrown a brick on the accelerator. After a bit, something would have been 'broken'.
slothman is offline  
post #7 of 9 (permalink) Old 02-12-2009, 01:44 AM
1st Gen FTW - It's AutoMedic!

 
cdmccul's Avatar
 
Join Date: Jun 2008
Location: Garrison, ND
Posts: 15,449
Feedback: 18 / 100%
                     
Hehehehehe, I don't remember the name of the company, but I bought a service contract along with my 1998 minivan I purchased in 2001. I paid right about 2K for it along with the van. I had a window switch go out, and they replaced that... then I had a control arm mount (not a single part failed, but the cradle had a failure), and they paid for that... I looked at the repair bills, and the grand total was something like 500 bucks... so, to this point, I've lost my @ss.

Well, then about 9 months into owning the van, I noticed the output shaft bearings on the tranny going. So, I brought it to the dealer... the dealer said "rebuild it, 2000 bucks". I said "call the service company, and get it done." The service contract company said "no". I said "Look at the contract, do the work." They said "no." I argued with them for 2 months, the van mostly out of my hands in the dealer's storage lot.

It finally ended with the service company 'authorizing' a USED transmission to be installed... with out my consent. I got the van back, only to find the USED transmission to be in WORSE shape than the one I had. I called the service company and complained... they said they had the right to do it... so, I asked them for a copy of the contract. It took a week, and I got this little letter. It contained the standard boiler plate blah blah blah... and then this little second piece of paper... it said:

"Addendum for the State of Iowa - No used parts shall be substituted or installed with out express consent of the vehicle owner."

THERE WAS MY OUT!!!! I was on the phone faster than anything. Called the dealer to find out why they installed a used unit and get the name of who said to do it, and then called the service contract company to chew them out something fierce! I had a brand new factory transmission installed less than a week later... The cost topped 3K for the new repair... plus the diagnostic costs, plus the used one they couldn't return... plus labor in and out a few times...

I made my money on that one!!! First, only, and LAST service contract I'll buy.

They are out to make money... so don't expect them to pony up the dough for more than half the purchase price... with out a fight at least!
cdmccul is offline  
post #8 of 9 (permalink) Old 02-14-2009, 12:00 AM
 
Join Date: Jan 2009
Posts: 63
Feedback: 0 / 0%
 
Quote:
Originally Posted by Xanman View Post
I've been getting alot of emails lately for companies offering warranties on cars up to 10 years old. The packages run between $800-$1200.

My Trep is reaching 8 years old and 175k miles.
I'm pretty sure my tranny is on its last legs and I know from experience that these are not cheap to replace. I paid about $2200 for a replacement tranny for my Explorer several years ago.

Has anyone purchased a warranty for their older Intrepid before?
If so, do you have any recommendations?

Thanks!
I dont know if you can get a warranty with 175K miles..... if you can then thats good. Im thinking of getting a warranty on my 04.... I have full insurance coverage on her now.....
Rigormortor is offline  
post #9 of 9 (permalink) Old 02-14-2009, 09:49 PM
Intrepid Pro
 
yiranhu's Avatar
 
Join Date: Jul 2007
Location: Powell Ohio
Posts: 1,778
Feedback: 9 / 100%
                     
Quote:
Originally Posted by slothman View Post
You should've thrown a brick on the accelerator. After a bit, something would have been 'broken'.
Too slow. Drain the oil. Then idle the engine until it is broken. Then fill the oil back up.

BTW, if you are worried about tranny in an intrepid, you should know that a used tranny with fairly low miles (like 50K) only costs like 80 bucks a pop from some junkyards. A ultra low miler can probably be had for like 200. There are people who can put a tranny in for you for like 200 bucks. So total + fluid filter = < 500
yiranhu is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome