Gauges not working after 2.7 to 3.5HO swap. - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 6 (permalink) Old 05-29-2009, 11:05 AM Thread Starter
 
Join Date: Jun 2008
Posts: 6
Feedback: 0 / 0%
 
Gauges not working after 2.7 to 3.5HO swap.

"Successful" swap from a blown 2.7 to a 3.5HO. Engine runs smooth, and car drives fine. However, several problems persist.

Problems:
Tachometer and Spedometer not working (they do light up however and the gas gauge DOES work)
Shift Display (does not identify what gear you are in)
Data Link Connector not working (getting LINK ERROR on simple OBD readers, and cannot communicate with PC-based reader)

Warning lights on: ABS (my SE does not have ABS, so this remains disconnected), Airbag, e-brake, Check Engine

My car: 2002 2.7L SE (not autostick)
Donor: 2000 3.5HO R/T (autostick)

3.5HO parts installed in the Engine Bay:
engine & transmission
PCM
TCM
Power Steering
Radiator/condensor/fan
AC lines (had to alter some old 2.7 parts to fit with the 3.5 but all is well)
3.5HO wiring harnesses

3.5HO parts installed in the Interior:
BCM and housing
Gauge cluster

My biggest frustration is being prevented from reading the codes through the data link connector. I have not found any fault in a connection and the data link wiring itself routs through the 3.5HO BCM, which is connected into the engine bay using 3.5HO wiring. made things even worse.

I'm also concerned about the lack of tach or speed. Anyone ever fix this easily or should I just replace the gauges altogether?

I'd appreciate any help on this one - I'm kind of at a loss as to where to go from here.
seven.dj is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-29-2009, 11:12 AM
Intrepid Pro
 
paintballdude05's Avatar
 
Join Date: May 2007
Location: Sudbury, Ontario
Posts: 13,180
Feedback: 13 / 93%
                     
I think were your main problem is that you put the wrong engine in there. Since your car is an '02 alot of the internal wiring changed between the 2000. Unless you re-did the whole wiring harness in the engine bay and inside the cabin I would say that's your problem.

Another possibility is that the cluster is not instaled properly so all the pins are not makind conection. Also, you said that you instaled the guage cluster from the R/T? Try instaling the one from your trep.
paintballdude05 is offline  
post #3 of 6 (permalink) Old 05-29-2009, 11:27 AM Thread Starter
 
Join Date: Jun 2008
Posts: 6
Feedback: 0 / 0%
 
I've tried both gauge clusters. Actually, nothing works at all on the 2.7 gauge cluster.

You're right on with the "wrong engine." But I have swapped all wiring because of that. All the wiring in the engine bay is 3.5HO. I've routed the 3.5HO wiring from the PCM/TCM in the engine bay to the 3.5HO BCM within the car. That feeds a 3.5HO gauge cluster. So I've tried so stick with all the specific make and model's parts. We've taken both entire dashes out of the 2002 and 2000, and verified that they are actually identical in every way. The wiring did not need to be changed in that.
seven.dj is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 05-29-2009, 11:43 AM
Intrepid Pro
 
paintballdude05's Avatar
 
Join Date: May 2007
Location: Sudbury, Ontario
Posts: 13,180
Feedback: 13 / 93%
                     
Quote:
Originally Posted by seven.dj View Post
I've tried both gauge clusters. Actually, nothing works at all on the 2.7 gauge cluster.

You're right on with the "wrong engine." But I have swapped all wiring because of that. All the wiring in the engine bay is 3.5HO. I've routed the 3.5HO wiring from the PCM/TCM in the engine bay to the 3.5HO BCM within the car. That feeds a 3.5HO gauge cluster. So I've tried so stick with all the specific make and model's parts. We've taken both entire dashes out of the 2002 and 2000, and verified that they are actually identical in every way. The wiring did not need to be changed in that.
Also, keep in mind there's something different about the gas tanks between the years. The BCM's also changed so I don't know what kind of impact that would have since you didn't change the dash harness. The men to talk to about this would be TFC or Daytrepper. Daytrepper acutaly did a complete wiring swap from '98 to '02 specs on his car and would know were you could have went wrong.
paintballdude05 is offline  
post #5 of 6 (permalink) Old 05-29-2009, 12:31 PM Thread Starter
 
Join Date: Jun 2008
Posts: 6
Feedback: 0 / 0%
 
Thanks a lot. We've got both dash harnesses, so that can be done as well.

Hell, it might have been easier to put the body of my car onto the chassis of the donor car (it had one entire side and trunk hit).
seven.dj is offline  
post #6 of 6 (permalink) Old 05-29-2009, 10:22 PM
I hit shit with sticks!


 
Daytrepper's Avatar
 
Join Date: Jan 2005
Location: Zebulon, NC
Posts: 37,153
Feedback: 21 / 100%
                     
Garage
Quote:
Originally Posted by seven.dj View Post
Thanks a lot. We've got both dash harnesses, so that can be done as well.

Hell, it might have been easier to put the body of my car onto the chassis of the donor car (it had one entire side and trunk hit).
No need to swap all that. I suggest going back to the 2.7 computers. If you put the 2000 computers in the 2002 car, and didnt swap all wiring in the entire car, that is likely why you are getting the errors, because not everything is compatible. Re-install your 2002 BCM and PCM, and harnesses, convert the engine to 02, and that should solve the problem, and give you much better results (including special PCM capability) then you would get with the current setup.

Check the link below, this all that needed to be done to the engine to make it run on the 2002 electronics. Hate to say it, but nothing at all needed to be replaced on the car.

https://www.dodgeintrepid.net/forums/t76738/

If nothing else, its about the same amount of work..., swap the body harness and dash harness, fuel tank, and emissions components in your 00 car into the 02 car, since youve gone this far already...but you will lose the advantages of the 02 stuff.


1998 Dodge Intrepid
President; Danbo's Truck & Diesel, Inc
Director of Speeding; Chornay Boomers of Youngsville, GmbH
President, Rush Drumming Ventures, LTD;

Last edited by Daytrepper; 05-29-2009 at 10:37 PM.
Daytrepper is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome