camshaft position sensor malfuntion. error code #p0340 - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
post #1 of 7 (permalink) Old 08-13-2009, 11:21 PM Thread Starter
Intrepid Newbie
 
Join Date: Aug 2009
Location: annandale, mn
Posts: 2
Feedback: 0 / 0%
 
camshaft position sensor malfuntion. error code #p0340

I have a 2003 intrepid with a 3.5 ltr.

I got the car with the engine light on, the code read camshaft position sensor malfuntion. I changed the sensor and the car ran great for 3 days. on my way home from work today it started to stutter at about 1/3 pedal and it is hard to start (I have to hold the pedal to the floor for about 3 seconds and when I let off it starts). The light came back on with the same code. Normally, I would say this is a fuel pressure problem, but the code is throwing me for a loop... suggestions?
carpetogie is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-14-2009, 12:28 AM
I hit shit with sticks!


 
Daytrepper's Avatar
 
Join Date: Jan 2005
Location: Zebulon, NC
Posts: 37,145
Feedback: 21 / 100%
                     
Garage
Sounds like the cam sensor may have went bad again. Check it and the plug and wiring to it.

There is a recall bulletin out about this, has to do with the cam sensors receiving too much voltage from the PCM IIRC, and causing them to fail repeatedly. It can apparently cause damage to the catalytic converters from the computer falling into a limp mode after it occurs.

There is a bulletin posted in this thread:

https://www.dodgeintrepid.net/forums/t164030/

This may or may not have something to do with your issue, first I would replace the cam sensor again, you may have gotten a faulty one.


1998 Dodge Intrepid
President; Danbo's Truck & Diesel, Inc
Director of Speeding; Chornay Boomers of Youngsville, GmbH
President, Rush Drumming Ventures, LTD;
Daytrepper is offline  
post #3 of 7 (permalink) Old 08-16-2009, 01:50 PM
Intrepid Pro
 
Torontofirecaptain's Avatar
 
Join Date: Apr 2004
Location: Whitby, Ontario
Posts: 3,934
Feedback: 71 / 100%
                     
Quote:
Originally Posted by Daytrepper View Post

There is a recall bulletin out about this, has to do with the cam sensors receiving too much voltage from the PCM IIRC, and causing them to fail repeatedly.
So they claim, however, I'll bet more than likely, it is the Chinese garbage that they are importing both factory & after market.
Quality is so poor, they cannot handle the 8 volts they are supposed to, so the PCM is reflashed to supply 7 instead, to make up for the crap.
Instead of fixing the problem, they just as a band aid to mask it.
Torontofirecaptain is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 08-21-2009, 09:43 AM
Intrepid Pro
 
SHAUN's Avatar
 
Join Date: Apr 2003
Location: Brampton, Ontario
Posts: 1,092
Feedback: 0 / 0%
                     
funny even after the recall done to my car i got the code P0340. back to the dealer she goes....
SHAUN is offline  
post #5 of 7 (permalink) Old 08-21-2009, 09:48 AM
Intrepid Pro
 
Duds's Avatar
 
Join Date: Oct 2006
Location: Ohio
Posts: 22,212
Feedback: 12 / 100%
                     
Quote:
Originally Posted by SHAUN View Post
funny even after the recall done to my car i got the code P0340. back to the dealer she goes....
that sux!
Duds is offline  
post #6 of 7 (permalink) Old 08-21-2009, 10:37 AM
Intrepid Pro
 
Patel.748's Avatar
 
Join Date: Jul 2003
Location: Delaware, Ohio
Posts: 8,464
Feedback: 0 / 0%
                     
I of all people have been chewing then son's of bitch sensors like none other. I got it reflashed the other day and so far (crosses fingers) has been ok. I was getting so bad that I had a ratchet in the center console ready to pull over, pop off the neg. terminal, chill for about 5 minutes, tighten her back up and was on my way.... Really annoying if you ask me.
Patel.748 is offline  
post #7 of 7 (permalink) Old 08-21-2009, 11:17 AM
Intrepid Pro
 
Duds's Avatar
 
Join Date: Oct 2006
Location: Ohio
Posts: 22,212
Feedback: 12 / 100%
                     
Quote:
Originally Posted by Patel.748 View Post
I of all people have been chewing then son's of bitch sensors like none other. I got it reflashed the other day and so far (crosses fingers) has been ok. I was getting so bad that I had a ratchet in the center console ready to pull over, pop off the neg. terminal, chill for about 5 minutes, tighten her back up and was on my way.... Really annoying if you ask me.
I wonder if they would still do the recall for me since I had the 3.5 upgrade??
Duds is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome