Heater Switch Does Not Function - Stuck on High - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 6 (permalink) Old 11-25-2010, 01:38 PM Thread Starter
Intrepid Modder
 
Join Date: Aug 2004
Posts: 472
Feedback: 0 / 0%
                     
Heater Switch Does Not Function - Stuck on High

Just like the title says, my blower is stuck on maximum...I can turn the heat or ac up and down to adjust temperature, but I have only one blower speed. And I can't even turn it off.

This is on a 97 Intrepid ES with automatic climate control.


Does anyone know an easy fix for this? My local mechanic says he usually has to replace the entire until with a junkyard unit that runs $80 (which is more than the whole car is worth about now)

I wonder if there is a quick or temperary fix for the switch...or even a way of simply wiring in an On/Off two position switch for the circuit.
IntrepidSportDriver is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-25-2010, 02:03 PM
Intrepid Pro
 
Join Date: May 2008
Posts: 8,218
Feedback: 2 / 100%
                     
Read past a part of the post.

Last edited by crypt keeper; 11-25-2010 at 03:05 PM.
crypt keeper is offline  
post #3 of 6 (permalink) Old 11-25-2010, 02:44 PM
Intrepid Pro
 
stroise's Avatar
 
Join Date: Aug 2003
Location: long island
Posts: 1,835
Feedback: 2 / 100%
                     
Thats a bit high. here in ny there $20 at the yard. take yours apart and clean the contacts with alcohol and q-tips. Clean the circuit board good. on the rotary manual one u might have to bend the arms inside to let it make contact with the board. Use a pencil eraser on the board to get the contacts surface back to life. Check for bad soldering connections. If the connections have a dull look redo the soldering. If they have a shiny look look closely and make sure there arent any cold solder joints.
stroise is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 11-25-2010, 03:03 PM
Intrepid Pro
 
dodgebob68's Avatar
 
Join Date: Feb 2010
Location: Panama City, FL
Posts: 1,235
Feedback: 0 / 0%
                     
Sounds likes the blower motor resistor is shot. That would be the first thing you want to check, and a lot cheaper to replace with a new part than the whole switch. Rarely does the switch go bad. If the fan motor only blows on high that's most likely your problem.
dodgebob68 is offline  
post #5 of 6 (permalink) Old 11-25-2010, 03:11 PM
Intrepid Pro
 
Join Date: May 2008
Posts: 8,218
Feedback: 2 / 100%
                     
The resistors for the atc in ah 1st gen are not cheaper they $207.79 even at Rockauto.
crypt keeper is offline  
post #6 of 6 (permalink) Old 11-25-2010, 03:36 PM
Intrepid Pro
 
dodgebob68's Avatar
 
Join Date: Feb 2010
Location: Panama City, FL
Posts: 1,235
Feedback: 0 / 0%
                     
Uh, ok. Forgot he's dealing with a first gen and ATC. I retract my statement.
dodgebob68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome