Bizzare Coolant Problem - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 5 (permalink) Old 09-30-2003, 02:17 PM Thread Starter
 
Join Date: Sep 2003
Posts: 36
Feedback: 0 / 0%
 
Bizzare Coolant Problem

I've searched the forums and no one has seemed to have the same problem... basically this is what happened:

I was driving a friend back to school and all the sudden the coolant just dumped out. Big puddle all over the road, and nothing left in the car. I pulled it over and came back to get it the next day.. filled it with water and drove it home. That was about a week ago, and it's been reliable since, not even a slow coolant leak. Any ideas?
96loaded is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-30-2003, 03:10 PM
 
Join Date: Apr 2003
Posts: 638
Feedback: 0 / 0%
 
How much coolant did you lose? There could have been air in your system and it forced the coolant out through the overflow hose. Otherwise... ????
eaglevision4me is offline  
post #3 of 5 (permalink) Old 09-30-2003, 04:22 PM Thread Starter
 
Join Date: Sep 2003
Posts: 36
Feedback: 0 / 0%
 
Near as I can tell I lost at least 60% of it, probably more.
96loaded is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 09-30-2003, 04:27 PM
Intrepid Pro
 
Join Date: Mar 2002
Location: Ottawa, Ontario, Canada eh?
Posts: 4,908
Feedback: 0 / 0%
                     
Check your thermostat.. it's been getting cooler out lately.. over the last week actually..

So try this.. they're only $12 or so canadian.. so even less in U.S. Funds.. find the appropriate one with proper factory temp specs.

remove yours, clean it, boil it in water, time how long it takes to open.. and keep note on how well it opens.

repeat with the new thermo.. and see if there's a difference.. sometimes when they're going down hill.. they may only partially open when getting old, or open very very slowly.. dangerously slow..which causes this to happen.

The same thing happened to me, and the boil test DEFINATELY confirmed it. I was shocked to see how bad my thermo was behaving.

That, or it could be a water pump going out on you. Any strange noises from your engine?
EvilDeadFan is offline  
post #5 of 5 (permalink) Old 09-30-2003, 09:00 PM Thread Starter
 
Join Date: Sep 2003
Posts: 36
Feedback: 0 / 0%
 
engine seems to run fine, water pump only has about 10k miles on it, max.... as far as the thermometer, I'm gonna try it, but why would that cause me to dump all of the coolant?

I'm not terribly familiar with how the coolant system is regulated.
96loaded is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome