Heat doesn't work - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 7 (permalink) Old 10-13-2003, 01:16 PM Thread Starter
Intrepid Modder
 
virtueixi's Avatar
 
Join Date: Apr 2003
Posts: 498
Feedback: 0 / 0%
                     
Heat doesn't work

Hey, its getting cooler now and whenever I try to turn the heat on, only semi warm air comes out and then just cool air....what could be the problem? I DON'T WANT TO FREEZE TO DEATH!!!
virtueixi is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-13-2003, 01:52 PM
Intrepid Pro
 
crombie's Avatar
 
Join Date: Feb 2002
Location: Maryland
Posts: 9,831
Feedback: 0 / 0%
                     
Heater core?
crombie is offline  
post #3 of 7 (permalink) Old 10-13-2003, 02:03 PM
Intrepid Pro
 
Join Date: Jun 2001
Posts: 3,574
Feedback: 0 / 0%
                     
Heater core could be blocked, thermostat could be stuck in the open position, various sensors, etc.

What year car?

Did you try to scan for codes?
TehKing is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 10-13-2003, 02:05 PM
Intrepid Modder
 
CEHE4KA's Avatar
 
Join Date: Oct 2003
Location: Philadelphia, PA
Posts: 623
Feedback: 0 / 0%
                     
If your heater core would leak, you would suffocate (happened to me. Fumes create a mist in the passanger compartment, first sign is condensation on the windshield, sometimes greenish from the coolant.

What could happen is that the hoses or the heater core are clogged. Then you have a problem. On one hand your heater is not working, on another, the rest of your cooling system is operating at higher pressures.

Wiggle the hoses first, check for small leaks, and then do a complete drain of system with some cleaners.
CEHE4KA is offline  
post #5 of 7 (permalink) Old 10-13-2003, 02:06 PM
Intrepid Pro
 
ottowrkr's Avatar
 
Join Date: Jun 2001
Location: Planet LX
Posts: 1,169
Feedback: 0 / 0%
                     
have you checked the coolant level ?Then check the heater hoses that go to the back of the firewall , if you have hot hoses going into the heater and it still blows cold air your HVAC blend doors could be not working or misaligned .
ottowrkr is offline  
post #6 of 7 (permalink) Old 10-13-2003, 02:37 PM
Intrepid Pro
 
RealSynthetics's Avatar
 
Join Date: Feb 2003
Location: Garden City, Michigan
Posts: 1,880
Feedback: 0 / 0%
                     
My GF's car is having a similar prob.

-Duncan
RealSynthetics is offline  
post #7 of 7 (permalink) Old 10-13-2003, 06:51 PM Thread Starter
Intrepid Modder
 
virtueixi's Avatar
 
Join Date: Apr 2003
Posts: 498
Feedback: 0 / 0%
                     
this sounds serious, I better take it to the dealer ASAP. thx
virtueixi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome