cluster problems - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 5 (permalink) Old 01-22-2004, 12:42 AM Thread Starter
 
Join Date: Jan 2004
Posts: 8
Feedback: 0 / 0%
 
Sad cluster problems

i have a 94 intrepid 3.3 that has sat for probably two or three months after putting in inner tie rod bushings. went to drive today and battery was dead so i put in a new one, while driving to work noticed the speedo, tach and radio are not working. radio comes on but no sound,oh yeh before i parked it i also put in a new bulb on the cluster, i think it twisted in. can someone help me with what to look for to fix these problems! it doesnt make sense, i guess sitting is bad for cars?
Back2Life is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-22-2004, 03:08 AM
Intrepid Pro
 
RealSynthetics's Avatar
 
Join Date: Feb 2003
Location: Garden City, Michigan
Posts: 1,880
Feedback: 0 / 0%
                     
I know this might sound obvious, but check the fuses. But if its not that, check for shorts or folded wires. That happened in my lincoln and took me forever to realize what the problem was. And even worse, mine was a digital display so i had NO clue what was going on when I was driving, it was an estimate for a few days.

-Duncan
RealSynthetics is offline  
post #3 of 5 (permalink) Old 01-22-2004, 10:20 AM Thread Starter
 
Join Date: Jan 2004
Posts: 8
Feedback: 0 / 0%
 
thanks for your input but i figured it out this morning, when i replaced the bulb in the cluster the way i was holding it and laid it down let the needles slowly creep all the way round backwards, then u end up installing it and they r stuck behind the little stop at the bottom just happened to notice the needles were behind it this morning! hey by the way do u know of a amp on the infinity systems in this vehicle and wher its located ? isuspect it to be the culprit of no radio sound, no fuses blown unless there is another fuse box
Back2Life is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 01-22-2004, 10:24 AM
.
 
Hypnos's Avatar
 
Join Date: Jul 2002
Location: Michigan
Posts: 9,861
Feedback: 0 / 0%
                     
There is an amp. The fuse for it is the same for the horn.
Hypnos is offline  
post #5 of 5 (permalink) Old 01-22-2004, 11:04 AM Thread Starter
 
Join Date: Jan 2004
Posts: 8
Feedback: 0 / 0%
 
thers a big possibility its bad because it was very distorted before i parked it but it used to work fine (car sits alot) now dosnt work at all
Back2Life is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome