low oil press light - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 15 (permalink) Old 11-05-2004, 03:33 PM Thread Starter
 
Join Date: Nov 2004
Posts: 2
Feedback: 0 / 0%
 
low oil press light

OK my low oil pressure light is coming on only when my car is stopped and goes to a but when i press the gas or start to go it goes off until i stop. does anybody have an idea of what could cause that? Thanks could some one e-mail me with an idea at [email protected]
master plan is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 11-05-2004, 06:13 PM
Intrepid Pro
 
Join Date: May 2003
Location: Abilene Texas
Posts: 2,074
Feedback: 2 / 100%
                     
check your oil level...also could be the oil sending unit...
silver&gold is offline  
post #3 of 15 (permalink) Old 11-05-2004, 06:17 PM
.
 
Hypnos's Avatar
 
Join Date: Jul 2002
Location: Michigan
Posts: 9,861
Feedback: 0 / 0%
                     
...Also could be a sign of sludge, in the case of the 2.7L...
Hypnos is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 11-05-2004, 06:28 PM
Intrepid Pro
 
Join Date: May 2003
Location: Abilene Texas
Posts: 2,074
Feedback: 2 / 100%
                     
I knew I forgot to add something.....
silver&gold is offline  
post #5 of 15 (permalink) Old 11-05-2004, 08:26 PM
Intrepid Pro
 
crombie's Avatar
 
Join Date: Feb 2002
Location: Maryland
Posts: 9,831
Feedback: 0 / 0%
                     
Quote:
Originally Posted by Hypnos
...Also could be a sign of sludge, in the case of the 2.7L...
Boy oh boy... mention oil and the 2.7 liter engine and everybody automatically assumes that there is sludge. Guess again cowboy! There is a technical service bulletin about the flickering oil light at idle (at a stop light). The tsb involves the oil pressure sending unit wiring. This is NOT FREE at a dealership. Remember recalls are free, TSB's are not. This tsb is not new to the 2nd gen community. It was announced a couple years ago.
crombie is offline  
post #6 of 15 (permalink) Old 11-05-2004, 08:30 PM
.
 
Hypnos's Avatar
 
Join Date: Jul 2002
Location: Michigan
Posts: 9,861
Feedback: 0 / 0%
                     
I am well aware of the TSB. But I have seen cases where people on here have just assumed it was the sensor. Shortly afterwards, thier engine fails.

Low oil pressure will make it flicker like that too. Sludge causes low oil pressure.
Hypnos is offline  
post #7 of 15 (permalink) Old 11-05-2004, 11:31 PM
Intrepid Pro
 
crombie's Avatar
 
Join Date: Feb 2002
Location: Maryland
Posts: 9,831
Feedback: 0 / 0%
                     
Quote:
Originally Posted by Hypnos
I am well aware of the TSB. But I have seen cases where people on here have just assumed it was the sensor. Shortly afterwards, thier engine fails.

Low oil pressure will make it flicker like that too. Sludge causes low oil pressure.
If you are "well aware" of the tsb on the sending unit, then why don't you mention that for once instead of sounding like a broken record... SLUDGE, SLUDGE,SLUDGE.... that kind of shit scares people who don't know much about DC engines. Sludge is not the only cause of low oil pressure...
crombie is offline  
post #8 of 15 (permalink) Old 11-05-2004, 11:35 PM
Intrepid Pro
 
dakotaquadsport's Avatar
 
Join Date: Oct 2003
Posts: 4,994
Feedback: 0 / 0%
                     
Quote:
Originally Posted by crombie
If you are "well aware" of the tsb on the sending unit, then why don't you mention that for once instead of sounding like a broken record... SLUDGE, SLUDGE,SLUDGE.... that kind of shit scares people who don't know much about DC engines. Sludge is not the only cause of low oil pressure...
Because it was already mentioned.....

Quote:
Originally Posted by silver&gold
check your oil level...also could be the oil sending unit...
then...

Quote:
Originally Posted by Hypnos
...Also could be a sign of sludge, in the case of the 2.7L...
And since the author did not leave any information regarding engine size, it could be any model year from 1993-2004, and any engine from the 3.3, to the HO 3.5. Because this is in the "General Discussion" area, not specific to the 2nd gen area or the 1st gen area. So if the author does come back on, please tell us your year and engine size.

Last edited by dakotaquadsport; 11-05-2004 at 11:40 PM.
dakotaquadsport is offline  
post #9 of 15 (permalink) Old 11-06-2004, 12:06 AM
Intrepid Pro
 
crombie's Avatar
 
Join Date: Feb 2002
Location: Maryland
Posts: 9,831
Feedback: 0 / 0%
                     
Quote:
Originally Posted by dakotaquadsport
Because it was already mentioned......
Oh it was? In this thread? Yeah the FIRST person to mention anything about the sending unit was Silver&Gold.... the FIRST person to say anything about the TSB was .... me.




Quote:
Originally Posted by dakotaquadsport
And since the author did not leave any information regarding engine size, it could be any model year from 1993-2004, and any engine from the 3.3, to the HO 3.5. Because this is in the "General Discussion" area, not specific to the 2nd gen area or the 1st gen area. So if the author does come back on, please tell us your year and engine size.
Yeah, thats actually a good point. It could be any year and any engine for that matter. But remember: Somebody cries a foul engine we all automatically know everything and assume the worse. Though some people never, ever have owned a 2.7 liter Intrepid. But what do I know? I have had mine since May 2002, and have put over 60k on the odometer.
crombie is offline  
post #10 of 15 (permalink) Old 11-12-2004, 04:13 PM Thread Starter
 
Join Date: Nov 2004
Posts: 2
Feedback: 0 / 0%
 
Thumbs down

My car has a 2.7 is a 1998 intrepid and I changed my oil and oil filter and the light has not came back on .... but i would like to thank you all for replying to the message and for your time THANKS AGAIN>>>> chat at you later
THE MASTER PLAN B
master plan is offline  
post #11 of 15 (permalink) Old 11-12-2004, 05:51 PM
Intrepid Pro
 
Join Date: May 2002
Posts: 4,553
Feedback: 0 / 0%
                     
Hey Master Plan....Check out my post in THIS THREAD. It should help answer your question. Also, if you haven't done so already, Switch to synthetic (Mobil 1) and a GOOD (Purolator Pure One) filter NOW!!!!!!!!!! You'll thank us all later!
slowbra is offline  
post #12 of 15 (permalink) Old 11-12-2004, 08:29 PM
 
Join Date: May 2004
Posts: 2,893
Feedback: 0 / 0%
                     
well when i was in my 3.3 my oil pressuer light came on and off more off then on.

we pulled the engine and the oil pick up was clogded full of metal oil dipstick peices. ill let you do the rest of the thinking
ESMIKE96 is offline  
post #13 of 15 (permalink) Old 11-12-2004, 08:34 PM
Intrepid Pro
 
Gorm's Avatar
 
Join Date: Jan 2003
Location: Iowa
Posts: 7,101
Feedback: 20 / 100%
                     
That exact same thing happened to me. Turned out to be that the oil sending unit was shot, replaced it...the light has never come back.

--Gorm
Gorm is offline  
post #14 of 15 (permalink) Old 11-12-2004, 08:42 PM
Intrepid Pro
 
crombie's Avatar
 
Join Date: Feb 2002
Location: Maryland
Posts: 9,831
Feedback: 0 / 0%
                     
Quote:
Originally Posted by Gorm
That exact same thing happened to me. Turned out to be that the oil sending unit was shot, replaced it...the light has never come back.

--Gorm
Jason: How much was part and labor?
crombie is offline  
post #15 of 15 (permalink) Old 11-15-2004, 09:00 AM
 
Join Date: May 2003
Posts: 1,992
Feedback: 0 / 0%
                     
"over 60k on the odometer."
TICK TICK TICK.........
alarkyokie is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
3.3L Oil LIGHT phatboy2nv General Discussion (First Generation) 8 01-25-2006 11:41 PM
Oil light auto_merger_man Chrysler Concorde, LHS, and Eagle Vision 5 08-23-2004 09:10 PM
Oil Light notasimpleway General Discussion 9 10-29-2003 06:32 PM
Oil Light !! Intrep95 General Discussion (First Generation) 11 02-02-2003 02:22 PM
Oil change process Snorton Norton Whatever 11 08-28-2002 12:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome