Problems with power. - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 3 (permalink) Old 11-10-2004, 04:13 AM Thread Starter
 
Join Date: Jan 2004
Posts: 6
Feedback: 0 / 0%
           
Problems with power.

I recently rebuilt my engine like 5000 miles ago. I have started to have problems with the engine...It seems to be loosing power...it studders when you first accelerate...then from 45 to 55 mph it jerks around...giving the engine a generous rev, it backfires out of my intake. I was just wondering if anyone knows what this is. Someone told me that it may be a piston ring because even though i rebuilt the engine, i only changed one piston, the main bearings, the crank and the piston rings.
please help.
Embracenrace is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-10-2004, 08:54 AM
Intrepid Pro
 
Join Date: Oct 2003
Posts: 2,254
Feedback: 0 / 0%
                     
backfireing out the intake sounds like a timinig issue to me, any stored codes?
mb-lhs is offline  
post #3 of 3 (permalink) Old 11-10-2004, 06:11 PM Thread Starter
 
Join Date: Jan 2004
Posts: 6
Feedback: 0 / 0%
           
the check engine light hasn't gone on...and there aren't any codes...im going to do a compression test tomorrow and see if maybe it could be my piston rings...someone told me that they could have not settled in right when i did the rebuild. But you think it may be timing? cam or chain because i never replaced the chain.
Embracenrace is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Steering problem kirrer General Discussion (First Generation) 3 03-28-2004 01:57 PM
Power outages Hypnos Whatever 36 08-17-2003 04:03 PM
I keep blowing my subs smc1377 Car Audio and Video 52 01-16-2003 04:18 AM
Talk about some power.... PopolZ Whatever 26 01-03-2003 09:04 PM
Has anyone had problems with power windows. mello5276 General Discussion (Second Generation) 12 04-01-2002 10:13 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome