Stock head unit problems... - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 (permalink) Old 11-30-2004, 10:41 PM Thread Starter
 
Join Date: Nov 2004
Posts: 5
Feedback: 0 / 0%
 
Stock head unit problems...

The radio in my trep is acting like it is posessed. Sometimes nothing will work except the letters will be lit, other times the clock will be on with no radio, and other times it works perfectly. If i take it out of the dash and hit it, it generally starts working , but id rather now do that all the time. The wires appear snug and all in the harness properly. Is this a bad head unit, or has anyone had this issue before and have a solution?
WeakVTEC is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-01-2004, 11:43 AM
 
Join Date: Feb 2002
Posts: 8,649
Feedback: 0 / 0%
                     
More than likely there's a bad connection internal to the radio...
dbaudiopro is offline  
post #3 of 4 (permalink) Old 12-01-2004, 07:37 PM
Intrepid Pro
 
Torontofirecaptain's Avatar
 
Join Date: Apr 2004
Location: Whitby, Ontario
Posts: 3,934
Feedback: 71 / 100%
                     
Those were bad years for the display-to-circuitboard connections going bad.
Used to have to pound the daylights out of my dash in the van until I replaced the whole unit.
There are guys on EBAY that charge $50 or so to repair. Check the "Chrysler CD" etc listings.
Torontofirecaptain is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 12-02-2004, 07:00 AM
Intrepid Pro
 
dakotaquadsport's Avatar
 
Join Date: Oct 2003
Posts: 4,994
Feedback: 0 / 0%
                     
My advice is to replace the headunit. Just get a totally different one and junk that one, mine did the same thing, and it took a whopping 5 minutes to change it out for another factory unit. I bought it off of another member on here for less than getting your current one fixed.
dakotaquadsport is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem(s) with new CD head unit rotorhead911 Car Audio and Video 11 07-14-2004 04:12 PM
Head Unit Question Silver01intrepidSE Car Audio and Video 4 02-26-2004 09:47 PM
Getting ready to install my Head Unit - Tips? Zaphod Car Audio and Video 7 08-25-2003 04:47 PM
Head unit? Moparpartsguy Car Audio and Video 10 01-26-2003 12:53 AM
OEM Head Unit CD/R mitchshin General Discussion (Second Generation) 15 12-21-2001 08:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome