Need help - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 3 (permalink) Old 06-18-2012, 07:39 PM Thread Starter
Intrepid Newbie
 
Pooh Gotti's Avatar
 
Join Date: Nov 2011
Location: Alaska
Posts: 12
Feedback: 0 / 0%
 
Need help

ok, to start off, i have a 03 intrepid SE w/ 2.7

what its doin is.. well, it comes and goes.. but its like it loses power and then it kicks back in, its worse at low speedz, kinda acts jerky and acts like it wants to stall but it doesn't, then you give it gas and it jerks like its runnin out gas (there is plenty) and then all the sudden it kicks in and has full power..then when i slow down, it wants to idle rough and lose power, then once again its jerky, and then you start to build speed, and bam... kicks back in.. only other thing I noticed was the oil light flickered for a couple seconds.
Pooh Gotti is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-19-2012, 12:07 AM
Intrepid Pro
 
bh1992's Avatar
 
Join Date: Jun 2011
Location: Osceola, IA
Posts: 6,393
Feedback: 1 / 100%
                     
Garage
first of all, take a look at the oil pressure sending unit to see if there is an oil leak there. It is a common place for a leak to form and it usually results in the oil pressure light flickering when the engine is up to temp. second, do you have any trouble codes?
bh1992 is offline  
post #3 of 3 (permalink) Old 06-19-2012, 07:24 AM
Intrepid Pro
 
Join Date: Feb 2002
Location: Virginia, U.S.
Posts: 16,196
Feedback: 4 / 83%
                     
Quote:
Originally Posted by bh1992 View Post
first of all, take a look at the oil pressure sending unit to see if there is an oil leak there. It is a common place for a leak to form and it usually results in the oil pressure light flickering when the engine is up to temp. second, do you have any trouble codes?
Not a bad idea to check for that, but I was thinking that in his case, the flicker is because the idle dips below normal (he said it almost stalls) and a new switch will likely do the same thing. IOW, fix the running issue, and the flicker will probably go away too.
peva is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome