My new amp-problem solving-please help - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 3 (permalink) Old 01-24-2002, 05:53 PM Thread Starter
 
Join Date: Jun 2001
Posts: 3,503
Feedback: 0 / 0%
                     
My new amp-problem solving-please help

Ok. About a week before x-mas my amp/sub worked no more. At this time I had a Sony amp rated at 200x1 watts RMS. I figured my amp had gone or I blew a fuse. I checked the fuses, they were fine. I thought for sure my amp had blown, but it didn't smell like it. I used this as an excuse to get a new amp. So I got me a Rockford Fosgate Punch 250.2 which is rated at 250x1 watts RMS. After hooking that amp up, still no bass from the sub. So the next thing was maybe the sub had blown. So I changed subs and still no bass. Now, since I have this hooked up to my factory radio I needed a LOC (Line Output Convertor). I now thought that the LOC blew. Well, since the LOC is located behind the radio it is kinda hard to get to. Since I didn't want to rip my dash apart, I took it back to the place I had it installed intially. They checked everything and what they found was that the LOC had blown (like I thought). So they installed a better LOC (Audiolink PL2).

The sub now works, but it is barely noticible. My Sony setup was 10 times louder! So I thought the gain setting on the amp needed adjusting. I tried both extremes (since RF doesn't like to label which is max and which is min on the gain control thingy). That didn't work. The LOC itself has an adjustable gain control. I think maybe that gain control (on the LOC) needs to be adjusted. What do you people think?

The Rockford amp setup should be just as loud, if not louder, than my Sony. But that currently is NOT the case.

Any other ideas as to what could be the cause? I plan on taking it back to the installation place on Monday to ask them what the fuck.

Thanks in advance,
-chase

[ January 24, 2002: Message edited by: Warlord187 ]
Warlord187 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-24-2002, 06:27 PM
 
Join Date: Jun 2001
Posts: 105
Feedback: 0 / 0%
 
That what I was going to say that the LOC has adjustments on it, and their probably set too low..
Barnz is offline  
post #3 of 3 (permalink) Old 01-24-2002, 09:35 PM
 
Join Date: Jan 2002
Posts: 187
Feedback: 0 / 0%
 
Nice graphic Barnz,

Reminds me of Duke Nuk'em 3D.

SHAKE IT BABY!

sURFN
sURFNmADNESS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome