900 hp Viper vs. a couple of Busa's - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 7 (permalink) Old 04-07-2004, 08:54 AM Thread Starter
Intrepid Pro
 
Maverick9110E's Avatar
 
Join Date: Jan 2002
Location: Northern NJ
Posts: 4,564
Feedback: 0 / 0%
                     
900 hp Viper vs. a couple of Busa's

http://www.nickslick.com/viper2.wmv

its a 19 minute video so if you have dial up, you have been warned.
Maverick9110E is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-07-2004, 09:15 AM
 
Join Date: Jan 2003
Posts: 4,155
Feedback: 4 / 100%
                     
saw that before....damn that is such a long ass video. for once i actually kinda wish they did one angle, because i can never figure out who wins in each race
01redMS is offline  
post #3 of 7 (permalink) Old 04-07-2004, 09:35 AM
 
Join Date: Sep 2003
Posts: 235
Feedback: 0 / 0%
                     
first bike its even, and the last 2 bikes kick its ass.
NiTeRiS is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 04-07-2004, 09:06 PM
Intrepid Pro
 
INTREPER's Avatar
 
Join Date: Oct 2001
Location: Irvine, CA
Posts: 2,576
Feedback: 0 / 0%
                     
That has got to be the geekiest pair of old guys riding Busas that I have ever seen.
INTREPER is offline  
post #5 of 7 (permalink) Old 04-07-2004, 11:58 PM
p3
Intrepid Pro
 
p3's Avatar
 
Join Date: Sep 2001
Location: The State of Boredom
Posts: 4,811
Feedback: 0 / 0%
                     
I've seen that one before. That car does pretty good considering what it's up against.
p3 is offline  
post #6 of 7 (permalink) Old 04-08-2004, 12:14 AM
 
Join Date: Feb 2004
Posts: 41
Feedback: 0 / 0%
 
Very cool video none the less. I saved it to my collection. Thanks.
Railcop094 is offline  
post #7 of 7 (permalink) Old 04-08-2004, 01:18 AM
 
Join Date: Sep 2002
Posts: 1,713
Feedback: 0 / 0%
                     
Nice vid.. ugliest vip I've ever seen!!! plus the guy wasn't shifting well enought IMO

Last edited by Jus' Trepping; 04-08-2004 at 03:50 PM.
Jus' Trepping is offline  
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome