strange explosion - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 11 (permalink) Old 02-14-2008, 03:43 PM Thread Starter
Intrepid Fan
 
Euro-poweR's Avatar
 
Join Date: Jul 2007
Location: Alamogordo, NM - USA
Posts: 193
Feedback: 0 / 0%
   
strange explosion

well, my car scared me senseless the other day, I was wondering what the hell happend.

I started my car and wasnt really paing attention. I only turned the key short, which usually isnt enough to start the car when the engine is cold. in any case, I though the engine was still off, since I didnt hear it because of blasting music. So just as a reflex I trun the key again.... well the engine was already on... usually ild expect an unfriedly rattering noise when I do that right? well this time I hurt a rediculusly loud bang and some smoke going down the right side of my car... I could not figure out where it came from. As soon as I got out of my car the smoke was gone... that was 3 days ago and the car has been acting completly normal since then, even right after that I started the car back up and it worked just fine. I havent noticed any leaks or visible damage, but it still scared me a lot... I thought I blew something.

Any idea what it could have been?
Euro-poweR is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 02-14-2008, 04:33 PM
Intrepid Pro
 
Join Date: Aug 2005
Location: Arlington Texas
Posts: 2,823
Feedback: 1 / 100%
                     
Backfire?
hardwareguy is offline  
post #3 of 11 (permalink) Old 02-15-2008, 05:50 PM Thread Starter
Intrepid Fan
 
Euro-poweR's Avatar
 
Join Date: Jul 2007
Location: Alamogordo, NM - USA
Posts: 193
Feedback: 0 / 0%
   
thats what I though... but I have never heard my car do that before, and the fair amound of smoke and how loud it was got me confused...
Euro-poweR is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 02-28-2008, 08:50 PM
Intrepid Fan
 
Join Date: Feb 2008
Location: Fernandina Beach Florida
Posts: 147
Feedback: 0 / 0%
 
Quote:
Originally Posted by Euro-poweR View Post
thats what I though... but I have never heard my car do that before, and the fair amound of smoke and how loud it was got me confused...
Where did it come from, the right rear or right front??
If it was the right rear, then it could have been one of your friends puttin a condom on your muffler so when your car runs the condom gets bigger and then pops and its REALLY loud.. small chance it was that.. but still..
surfin_mopar is offline  
post #5 of 11 (permalink) Old 02-28-2008, 09:01 PM
Intrepid Modder
 
neuroticdave's Avatar
 
Join Date: Nov 2007
Location: Jersey City, NJ
Posts: 739
Feedback: 0 / 0%
                     
Quote:
Originally Posted by surfin_mopar View Post
Where did it come from, the right rear or right front??
If it was the right rear, then it could have been one of your friends puttin a condom on your muffler so when your car runs the condom gets bigger and then pops and its REALLY loud.. small chance it was that.. but still..
Hahahhaa, guilty!

But seriously, prob. a backfire.
neuroticdave is offline  
post #6 of 11 (permalink) Old 02-28-2008, 09:02 PM
Intrepid Pro
 
sc.intrepid's Avatar
 
Join Date: Aug 2004
Location: Charleston, SC
Posts: 4,600
Feedback: 5 / 100%
                     
Intrepids have that anti-grind starter feature(don't they?). If the car is running, it won't power the starter relay. So you didn't grind anything. You may have blown some electrical component like a relay or something in the circuit.
sc.intrepid is offline  
post #7 of 11 (permalink) Old 03-01-2008, 04:55 AM Thread Starter
Intrepid Fan
 
Euro-poweR's Avatar
 
Join Date: Jul 2007
Location: Alamogordo, NM - USA
Posts: 193
Feedback: 0 / 0%
   
I thought about the condom thing, but that wouldnt explain the smoke would it?.. besides the tip of my exhaust is chromed and wouldnt hold a condom on there tight enough to blow up.... anyway, a banana or something may have been... I was late for class already and just checked under the hood, because I thought thats where the smoke came from.

Its been a while now and have not noticed any further problems along those lines. It probably was just a odd backfire. THe electrical thing may be a possibility, but I am sure I would hae noticed anything going out by now.

Thanks for all the input about this thing.
Euro-poweR is offline  
post #8 of 11 (permalink) Old 03-01-2008, 05:12 AM
Speed is Power
 
NHogan's Avatar
 
Join Date: Dec 2004
Location: Iowa, USA
Posts: 6,683
Feedback: 37 / 100%
                     
Maybe its just the 2.7.

Just kidding, gotta make fun of the 2.7 members all I can
NHogan is offline  
post #9 of 11 (permalink) Old 03-01-2008, 02:52 PM Thread Starter
Intrepid Fan
 
Euro-poweR's Avatar
 
Join Date: Jul 2007
Location: Alamogordo, NM - USA
Posts: 193
Feedback: 0 / 0%
   
Quote:
Originally Posted by nhogan View Post
Maybe its just the 2.7.

Just kidding, gotta make fun of the 2.7 members all I can
Haha, go for it.... the 2.7 sucks, we all know that (especially the 2.7 owners ;) )... but mine has been reliable so far and I keep it clean... only Premium gas and synthetic oil... if you take care of your stuff, it will last you... even 3.2s or 3.5s crap out if you dont take care of them.
My buddies 3.2 ES is slower and in a way worse shape then mine
Euro-poweR is offline  
post #10 of 11 (permalink) Old 03-01-2008, 03:06 PM
Intrepid Fan
 
Join Date: Oct 2007
Location: RI
Posts: 204
Feedback: 2 / 100%
 
Are you allowed to make fun of 2.7s when you have a 1st gen?
Sovnade is offline  
post #11 of 11 (permalink) Old 03-02-2008, 01:24 AM
Speed is Power
 
NHogan's Avatar
 
Join Date: Dec 2004
Location: Iowa, USA
Posts: 6,683
Feedback: 37 / 100%
                     
Quote:
Originally Posted by Euro-poweR View Post
Haha, go for it.... the 2.7 sucks, we all know that (especially the 2.7 owners ;) )... but mine has been reliable so far and I keep it clean... only Premium gas and synthetic oil... if you take care of your stuff, it will last you... even 3.2s or 3.5s crap out if you dont take care of them.
My buddies 3.2 ES is slower and in a way worse shape then mine
True that my 3.5 engine went out at 96K

Quote:
Originally Posted by Sovnade View Post
Are you allowed to make fun of 2.7s when you have a 1st gen?
I'm allowed to do alot of things lol.
NHogan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome