New FORD Guy now with Intrepid - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 11 (permalink) Old 11-12-2003, 01:05 AM Thread Starter
 
Join Date: Nov 2003
Posts: 99
Feedback: 0 / 0%
 
New FORD Guy now with Intrepid

Hello Everyone,

I'm new to the Chrysler gig, but I came across a used Intrepid that should hopefully work as my daily driver. I like Fords for rodding, and I've had some very dependable "Blue Ovals."

This Dodge has a few problems, but your forums have been quite helpful. I brought it home "limping" with no speedo, so I'll be troubleshooting some sensors or a solenoid pack. I also have a left pull in front. I plan to inspect the front end over the week (just got it home tonight) and hopefully zero in on that problem too. Its funny how most cars, regardless of brand, seem to have weaknesses that nearly everyone has experienced. That's the great joy of specialized forums like this one.

I'm a grease monkey at heart and am not afraid to tear anything apart, so I'll be doing my own repairs. I'll be checking here regularly because of all the good info and help. Also, if anyone needs help with Fords, give me a yell.

Thanks for having and maintaining this great resource...

Joseph

Here's my new lady friend...a 1994 ES

https://www.dodgeintrepid.net/photopo...cat=508&page=1
Native Gearhead is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 11-12-2003, 01:19 AM
Intrepid Pro
 
Ravin's Avatar
 
Join Date: May 2002
Location: Maine
Posts: 4,288
Feedback: 0 / 0%
                     
defintly sounds like either an input or an output sensor on the tranny went.....easy fix and cheap.
welcome to the site!
Ravin is offline  
post #3 of 11 (permalink) Old 11-12-2003, 10:26 AM
 
Join Date: May 2002
Posts: 849
Feedback: 0 / 0%
                     
ouashtay!

welcome to di.net -- hope you get many good miles from your Trep.


and yes, Custer wears an Arrow shirt!
concordia is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 11-12-2003, 10:34 AM
 
Join Date: Apr 2002
Posts: 1,527
Feedback: 0 / 0%
                     
Welcome to the board!
2001RT is offline  
post #5 of 11 (permalink) Old 11-12-2003, 10:59 AM
Intrepid Pro
 
crombie's Avatar
 
Join Date: Feb 2002
Location: Maryland
Posts: 9,831
Feedback: 0 / 0%
                     
Native Gearhead: your trep looks very nice! Welcome aboard!

BTW: I like that color on 1st gens.
crombie is offline  
post #6 of 11 (permalink) Old 11-12-2003, 03:51 PM
Intrepid Pro
 
Gaze's Avatar
 
Join Date: Jan 2003
Location: South Jersey
Posts: 6,362
Feedback: 8 / 100%
                     
Crombie has 1st Gen envy...
Gaze is offline  
post #7 of 11 (permalink) Old 11-12-2003, 04:12 PM
Intrepid Pro
 
dabirdzR/T's Avatar
 
Join Date: Jul 2002
Location: Myerstown, PA.
Posts: 6,788
Feedback: 7 / 100%
                     
welcome to the site, enjoy and have fun!!
dabirdzR/T is offline  
post #8 of 11 (permalink) Old 11-12-2003, 04:58 PM
DIT
Intrepid Pro
 
DIT's Avatar
 
Join Date: Jul 2003
Location: New Kensington, PA
Posts: 2,333
Feedback: 2 / 100%
                     
she looks purddy, And welcome to the site!
DIT is offline  
post #9 of 11 (permalink) Old 11-13-2003, 12:24 AM
 
Join Date: Mar 2003
Posts: 228
Feedback: 0 / 0%
 
Welcome to DI.net, hope you enjoy your Intrepid and have a good experience with it. Patch 'er up and should run just fine for long time.
And I've got a problem with Fords; the slow things are always in my way!!! j/k, lol.
Just RAM It is offline  
post #10 of 11 (permalink) Old 11-13-2003, 08:17 AM
Intrepid Pro
 
RealSynthetics's Avatar
 
Join Date: Feb 2003
Location: Garden City, Michigan
Posts: 1,880
Feedback: 0 / 0%
                     
Welcome to our humble home. You'll find all the help you need here. If you need any at all :p These family sedans are among the coolest!

-Duncan
RealSynthetics is offline  
post #11 of 11 (permalink) Old 11-13-2003, 01:42 PM Thread Starter
 
Join Date: Nov 2003
Posts: 99
Feedback: 0 / 0%
 
Thanks for the welcomes, all.

Even though this car was limping, its performance was pretty good. The idle is real smooth. The interior is immaculate...plain spotless! It was a "one-family car", father to son. It was sold because of limp mode engaging after it got spun around in an accident. The body damage is relatively minimal and confined to the passenger side door panel and rocker. There is no rust whatsoever on the body.

I don't know too much about the option package, but it has a rather sophisticated factory sound system made by infinity, and it has a whole bunch of speakers arrayed in a "surround-sound" configuration (also from the factory). The Radio/CD is made by "Infinity". The sound is super, so I won't need to upgrade for a long time.

There are a couple of what look like electronic "glitches" that may be associated with the sensor problem (maybe?). I checked the door panel fuses and they all are intact, but I have not checked the fusebox under the hood.

My radio faceplate does not light or keep time, but the sound system works and the radio channel seek is fine. The CD player and controls all work. And the tiny lights on the graphic equalizer glow, but those are the only things on the radio that light up.

The LED shift selector first lights up in "P" when I start the car, but when I put the car in gear or reverse, all of the shift selector LED's light up and remain on until I turn the car off. I don't know if the shift console letters are supposed to light up (next to the gear shift), but they don't, even with the lights on.

All of the interior and exterior lights work fine, and the start-up lighting sequence seems to be normal, and the "message center" seems to be working OK. The power door locks and windows all work. The AC freezes you out, and the heater and vent positions also seem to be doing what they're supposed to be doing.

The hood hydraulics are shot, I'll have to use a 2 X 4 until I get replacements. The only other problem is that the plastic headlight lenses are "foggy", but not moisture. Just cheap "milky" plastic.

It has 16" aluminum wheels and a 3.3L.
Native Gearhead is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome