My 95 ES Won't accelerate - Tach Drops - DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 (permalink) Old 02-23-2004, 06:11 AM Thread Starter
 
Join Date: Feb 2004
Posts: 4
Feedback: 0 / 0%
 
Question My 95 ES Won't accelerate - Tach Drops

My 95 ES was running sweet up until I driven it one morning to work at hi speed and came off expressway and immediately hit a bunch of pot holes and broken ice. The car got rattled and then immediately began to act funny. When I would attempt to accelerate and she would reach about 2,000rpm the tach / engine would suddenly drop. If I attempt to push thru-it, she would pick up speed but feel like she wanted to die. However, at idle she would be fairly stable, with an occasional "miss" (post pot hole incident mind you), but seem to idle rather normally. Another odd symptom is that as I try to push thru-it the cruise control light intermittently flashes on, and off when I back off the accelerator. One mechanic said "we need to start with a tune-up" - I took it home and did the tune up (plugs and wires). Still has the problem. Another mechanic says it is in a "open-loop state" (running rich and causing some back-firing) and won't go closed loop, but doesn't throw any computer codes or check engine light. He recommends "we start with a PCM replacement". I feel uneasy about spending the $600 on a computer when he cannot even be sure it will solve the problem - and besides, there aren't any codes or chk engin light. ANY IDEAS? ANYONE EVER EXPERIENCE SUCH SYMPTOMS?
I suggested they check out the O2 sensors since my Hyanes manual makes reference to the car remaining in open loop when these go bad.
MikeyC is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-23-2004, 04:44 PM
 
Join Date: Jan 2004
Posts: 496
Feedback: 0 / 0%
 
thats wierd, could this be limp mode?????
Methman is offline  
post #3 of 4 (permalink) Old 02-23-2004, 09:26 PM Thread Starter
 
Join Date: Feb 2004
Posts: 4
Feedback: 0 / 0%
 
I read "limp mode" referenced in the earlier postings but I am not sure how it was defined....
MikeyC is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 02-25-2004, 12:15 PM
Intrepid Pro
 
Gorm's Avatar
 
Join Date: Jan 2003
Location: Iowa
Posts: 7,101
Feedback: 20 / 100%
                     
Hey dude,

You might get some more help if you post this in the first gen fourm. Usually members who might know of this type of problem don't ususlly see the problems in this thread.

But welcome anyways! Glad you like the site.

--Gorm
Gorm is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome