DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat - Reply to Topic
Thread: Cooling issue Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

Member names may only be composed of alpha-numeric characters. (A-Z and 0-9)

!!ATTENTION ADVERTISERS!! If you intend on advertising anything on this forum, whatsoever, you are required to first contact us here . Additionaly, we do NOT allow BUSINESS NAMES unless you are an Authorized Vendor. If you own a business, and want to do sales on this site via posting or private message, you will need to follow the rules. Shops, Stores, Distributors, Group Buys without being authorized will see your account terminated.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options
Rate Thread
If you like, you can add a score for this thread.

  Topic Review (Newest First)
04-25-2019 01:05 AM
Veeb0rg These cars use a closed loop cooling system. There is a radiator cap, its just not on the radiator like they commonly are, the cap on the coolant tank is where it is located. If its not overheating then the system it working as it should.
04-24-2019 10:53 PM
Barry Hi.name is Barry and its my first time here and i really need some input.i have a 97 intrepid 3.3l and there is no rad.cap.my coolant resevoir is full,no leaks,not overheating,but i dont think any coolant is being distributed through my engine.tank water never gets low and never moves.any help? Thanks! i havnt checked the thermostat yet was hoping to get some advice first.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome