DodgeIntrepid.Net Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Car died last night - opened the hood, and i'm looking at shattered covers over the top of each chain, chain is visible. WTF? I have pix i will post as soon as i find the SD card thing. What the hell would make this happen. never had this one before....Screwed!!!!!!!!
 

·
That rhythm is INFECTIOUS.
Joined
·
18,595 Posts
Yeah, sounds like you've had a catastrophic failure there - unfortunately the same failure all too common to the demise of most 2.7l motors...

Sorry to hear. Depending on the overall condition of the rest of the car, may be worthwhile to pursue swapping out the motor for a 3.2 or 3.5 (98-01).
 

·
Registered
Joined
·
223 Posts
Car died last night - opened the hood, and i'm looking at shattered covers over the top of each chain, chain is visible. WTF? I have pix i will post as soon as i find the SD card thing. What the hell would make this happen. never had this one before....Screwed!!!!!!!!
Had a similar thing happen to me last year. Only mine did not break through the covers. They said it was the water pump that failed causing the change to break. The whole thing cost me about $1700.00 after all was said and done.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
terrific. I'm having it towed back to my house soon - i'll take a couple pix and out em up. I know about the oil pump probs, the sludge probs, never heard of this one. anybody else ever deal with this specifically. Interior is perfect, exterior ok, but i just bought the damn thing 6 weeks ago!!!!!!
 

·
Premium Member
Joined
·
18,390 Posts
Besides the obvious damage local to the timing area, you might have some valve damage if it spun out of time immediately after the failure.
 

·
Registered
Joined
·
223 Posts
Besides the obvious damage local to the timing area, you might have some valve damage if it spun out of time immediately after the failure.
The shop I took mine to after my timing chain broke said I was lucky this did not happen to me. I hope you are lucky too. When they showed me the chain it was like some monster had taken a bite out of it and the water pump was in two pieces.

My suggestion is to take it someplace that knows about the intrepid timing chain. The place I took mine to took 9 days to complete the job because they had to refer over manual after manual to open the whole thing up...they had never done an intrepid before. Must be something special about how its all put together.

As for this being a common thing...I do know one other guy who had this happen to him, with the water pump failing and sending the chain off. It happened at about 90,000 miles. And as for the sludge issue. If you've got an '01 I've been told that it doesn't occur in the '01 as frequently as it did with the '00. They fixed something from what I've heard. And low and behold when they opened mine up it was nice and clean. Oil is always free of any gunk. If that makes you feel any better.

Good luck!
 

·
Registered
Joined
·
979 Posts
Most unfortunate. That doesn't look good and there is a high probability that the valves smacked the pistons.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top