DodgeIntrepid.Net Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Folks - My '95 3.3L Concorde (172,000 miles) has been a great car since I acquired it back in 2013. It has sat for about 4 months with very little use. The other day I fired it up an noticed:
  • Instruments dead (tach, speedo, temp, fuel)
  • Windshield wipers not working
  • Door locks not working
  • Air Bag light is on
  • Blower fan is on full blast with no other HVAC controls working
  • RPM needle does move off of dead zero with ignition on but no further

Battery is at 13.5 - 14V. Runs fine. No trans shifting issues. All fuses are good. #14 and #17 have power on both sides of fuse. After reading many other threads related to the instrument cluster, I am looking to remove / replace the ignition switch.
  • Does this sound like the right causal for my problem?
  • How does the plastic steering column cover separate? Lower corner closest to back side of steering wheel at 7 o'clock position does not want to separate. Afraid I will break it.

Any advice?
 

·
Registered
Joined
·
4,393 Posts
Ign switch is a known issue for some things. It's a good start. But I would also checkign wiring for chewing from rats.

Far as column cover, I do wanna say there are three or four screws (wanna say torx?) that hold it on, and one that bolts to the actual column. Been so long since I had mine on.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Changed ignition switch and no change. Definitely have power at the 20A and 40A leads going to the ignition switch. Should I be looking at removing instrument cluster and see if there is any discontinuity visible or should I be looking for a bad ground. I read the ground point to the right of the gas pedal is a likely one to check. Any other ideas?
 
1 - 5 of 5 Posts
Top