DodgeIntrepid.Net Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My Chrysler will drive 10 miles then over heat.I pull over and there is pressure built up and it's wet around overflow.I replaced the 18 lb cap and bled system but still builds up pressure and comes out cap.
When it gets hot I will open bleeder on housing and nothing but air comes out. For the entire time.
I noticed it comes out of overfill cap on reservoir more with higher rpms
And gets hot. My question is does this sound like a plugged radiator or bad thermostat?
I noticed when I turned petcock on bottom of radiator to drain coolant it only trickled out not a stream
Hope someone can help
Thanks
 

·
Registered
Joined
·
348 Posts
how fast does the pressure build?
sounds more like head gasket failure if the pressure builds right after start.
once over heated, it will steam for quite some time til it cools enough.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
No after start from cold I drive it 10 miles and then it starts getting hot.
My radiator hoses are spungy I'm thinking collapse after they get warm
Maybe stuck thermostat.there is no water in oil or any steam or moisture out tail pipe and car runs very smooth..
It's driving me crazy.
 

·
Woober Goobers!
Joined
·
50,048 Posts
2007 300 is an LX vehicle. LXforums is where you should be.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
how fast does the pressure build?
sounds more like head gasket failure if the pressure builds right after start.
once over heated, it will steam for quite some time til it cools enough.
Thanks for the help I replaced upper and lower radiator hoses and T stat and the problem is gone..Hope it stays gone 👍
 
1 - 5 of 5 Posts
Top