DodgeIntrepid.Net Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
A new front end is necessary. tore off the bumper, radiator, radiator support, etc. basically i'm down to the crossmember on bottom for my 3.3. now i need to know if i can just bolt the radiator, support, bumper, and hood from a 97 3.5 in and go. also wondering if i could steal the power steering pump (i got a whistler, bad...) and water pump if they're decent.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
it started as the nice dark green (metal flake) but the guy who owned ronnie (yes, named my car. veronica rattlehead. she likes megadeth) neeeever maintained ****, so it's mostly primer black now. red primer rims too. They treated this car so bad that when i pulled the valve covers off, i had no clue that there were ever gaskets in there before. i kinda figured the rest would work, but thanks for the reassurance man. and 701 pride! think the brakes would be easy enough to snag too? i have no back ones whatsoever now, weak front ones (mechanics.... ugh.) and i'd reaaaally like to have those before driving again.
 

·
1st Gen FTW - It's AutoMedic!
Joined
·
15,449 Posts
You turn your own wrench, or hire it all out? Everything will swap over in the first gen years, with few exceptions, and with a few MINOR changes... The fenders on your car may be plastic - where the fenders on the 97 WILL be metal - but even if different materials, they will bolt up with some creativity.

The brakes will swap over as long as you have the whole donor car, or as long as you have the same type of brakes on both cars.
 

·
Premium Member
Joined
·
15,507 Posts
Ps pump, no go, same for water pump, everything else is a green light
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
replaced the front end damage, bled the radiator, took it around the trailer court 6 times, green lights all around. now today i added a little coolant, let her warm up, and started on my way. got about 5 miles on her and she died. wouldn't start up again without lights or hazards on, and if i turned em off it'd die again. then it died permanently, and if i turn the lights/hazards on, the horn blares til i turn em off again. any ideas? won't run now, even with the horn blaring
 
1 - 10 of 10 Posts
Top