DodgeIntrepid.Net Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
246 Posts
Discussion Starter · #1 ·
Guys: I tried swapping the in-hood breaker and the relay inside, but the horn still does not work. I am thinking it might be the speaker itself that blows the sound? Where is the speaker ? under the hood? any clues.

Looked underneath the steering for any lose wires - nothing there. With the traffic and the way people drive, need the horn to warn the idots on the road.
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #2 ·
ANYONE PLEASE help. Both, circuit breaker and relay are tested fine. Suspect something in the wireing.
THIS IS BECOMING VERY ANNOYING. Last week, while in the parking lot of WalMart, a woman un-parked her brand new SUV and started rolling reverse to get out, as I was looking for a spot. My heart missed a beat, as I could'nt warn her I was right behind her, due to the horn not working - I started to reverse so she would miss me, and it then that she fortunately realised that I was behind her, and stopped in the nick of time.
Is there a way I can open the steering part and mend this? OR, is there something I can install as a new system that substitutes the horn (if the original repair is cumbersome, or not worth troubleshooting / fixing)??
 

·
Registered
Joined
·
119 Posts
Aren't the relays the same part throughout? So you can switch relays around to test those. You can also put straight power to the horns under the hood to see if those work. They are on the front, facing down. You can crawl under the car and find them there on both sides. If all those work, perhaps it's a switch or wiring issue. You can splice in a cheap button switch and mount it to the dash or console. Or if the whole thing is screwed, you can get a horn kit from JC Whitney or similar, and follow the directions. This should be a pretty cheap and easy fix/rig. If you don't understand how battery power, switches, wiring and relays work, I suggest you take it somewhere to get it fixed. That shouldn't cost too much... relatively anyway.
 

·
Registered
Joined
·
4,388 Posts
I believe there are 2 horns, and they are mounted underneath the front end, on the frame rails (pretty sure). At least they look like horns on mine when I was under there over the weekend doing brakes.
 

·
Registered
Joined
·
1,158 Posts
Buy a horn in a can only a couple of bucks and its a for sure thing you will be heard by the whole nieghbor hood j/k I personally would be carefull until one of the guys to pipe in with a resolution. Gotta give it time for the responses
 

·
Registered
Joined
·
246 Posts
Discussion Starter · #7 ·
Checked the two horns underneath on both sides - Nothing much I could do.

Anyone ever had this issue, if so please direct me. I really want to mend this, OR add a new one. Anyone has suggestions, please??
 

·
Registered
Joined
·
1,992 Posts
Not being smart, but did you checka the fuse 18 in the junction block under the hood?
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top