DodgeIntrepid.Net Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter #1
Hey all... New to the site. I've had my '93 Vision since June of '03. Great car. Great look. I've got the 3.5L V6 and man she goes. I will get some pics up as soon as I get the chance. Now, onto the question(s).
I just got a little work on the car done at a dealership (the car has 147,000+/-). I'm still having some issues.
1) The back brakes seems to be dragging. I've looked, and don't see anything, and nothing seems to be loose. Has anyone had that problem?
2) There seems to be a something loose in the front end. I remember reading a recall on the car for connecting brace or something. The steering is really loose to go straight I'll be steering at 11 o'clock, and then to 1 'clock. Anyone?
3) Transmission... The transmission runs great. It's when I'm stopped it doesn't. It idle's (in drive) at about 600 rpm. When slowing to a stop, the engine drops down to about 800 rpm, slides up to about 1100, and then there's a hard shift down as I stop completely, and the rpm drops to 600. I plan on gettin the fluids changed, but could there be something else I need to get done?

I do a lot of driving in this car. It's my way of getting me and my instrument to my band's gigs (not to mention my girlfriend lives an hour away).

This is a great site. I've been checking it out for a week or so. great advice, and you all seem very friendly!

Thanks,
Kenny "The Icecream Man"
 

·
Registered
Joined
·
273 Posts
Discussion Starter #3
I took a quick look (it's been pretty damn cold out!), and couldn't see if the breaks were releasing or not... it looked like they were...

Thank you for the welcome... Y'all are a great group, glad to have found ya and joined up.

Erdenheim is just outside of Philly... We're fifteen minutes from everything... King of Prussia, Willow Grove, Center City Philly (about five minutes from Ft. Washington).

Weather is supposed to be great this weekend... So I'm gonna be under the hood, and probably have the car up to get a closer look to the wheels (all four corners).

Kenny "The Icecream Man"
 

·
Registered
Joined
·
175 Posts
Welcome!!
 

·
Registered
Joined
·
101 Posts
Having a 93 Vision with a 3.5L myself I can give the following advise:

1. If your rear is dragging, check your parking brake. The parking brakes are like little mini drum brakes inside the back disc brakes. I had a "seizing" feeling and within a week I had destroyed the parking brake on the passenger side. You can't see anything externally, but try jacking it up, taking the wheel and caliper and rotor off to take a look at the parking brake mechanism inside.

2. Something loose in the front end and lack of steering response could EASILY be from worn out inner tie rod bushings. Take a look at them, they are behind the engine right next to the firewall.

3. I had the same problems with my cars RPMs and thought it was the transmission as well. After a thorough tranny diagnostic including a fluid change and new input output speed sensors it was still there. There are two things (at least for me) that actually cleared it up. The first was cleaning the Idle Air Control motor. There is a post here on how to do it - look for IAC, its simple - takes 5 minutes , some throttle body cleaner and a T15 torx screwdriver (I think it was T15 anyway). The other thing was a new EGR valve. This isn't cheap and can take a couple of hours but you can do it yourself. Some people say to just replace the solenoid, but I did the whole thing including removing the plenum to make getting at the valve itself more easily.


If you do get the fluids changed in your tranny, make sure to get only ATF+4 fluid. It's expensive and available almost exclusively through dealerships but it's worth it in the end. Also have the filter changed by doing a pan drop.

Good luck and let us know how it goes.
 

·
Registered
Joined
·
273 Posts
Discussion Starter #6
Thank you all for the advise!
The car is being inspected right now as I type this. So if there's anything with the brake system, they should be able to point it out.
(Cross your fingers with the emissions though... I'm holdin my breath...)

When I get the car back (hopefull after work...) I will take a look at the IAC, give that a cleaning. If that takes care of things, I'll wait a few more weeks for the tranny fluid change.

The car was my rent's friends, and they kept ALL the paper work (there's receipts from EVERY oil change ever done on the car! Hehehe...), and I think I saw something on a tranny overhaul suggested at 101,000.. I've yet to see the work was done.

Thank you all again!
Kenny "The Icecream Man"
 

·
Registered
Joined
·
273 Posts
Discussion Starter #7
Car passed... Barely... And boy was it a screw job... Hehehe...

(you can check the post in general posts... I don't know how to link to that yet)

They found nothing wrong with the brake system... so it must just be in my head...

I'll keep you posted!

Thanks again...
 

·
Registered
Joined
·
273 Posts
Discussion Starter #8
It's been a while since anyone posted anything for the Eagle's!
So I'll give a little update...
Everything is running very well! I changed the coil and the alternator this weekend... But other than that, the engine is running very well... I've got some plans now that my buddy has his garage all cleared out... We might paint our cars... With that ability, I might shave my door handles, and probably the fuel cap filler. It's still in the planning stages (waiting for a few more pay checks from the band). I also want to rebuild the engine/tranny over the summer. Do up everything real nice. stainless steel braided hoses, and some good (red - to match the paint) vacuum lines also... Still toying with the idea of a new muffler... Well... how is everyone else out there in Eagle land?
 

·
Registered
Joined
·
175 Posts
That sounds good, Ice Cream Man.
Keep us informed about your progress.
I am planning to change my muffler on my Vision. However, I am now quite confused about what type of muffler is my Eagle using right now. The previous owner seems have changed the muffler. So, I have to figure it out first.

Other than that, I will change my intake to K&N filter also.

Good luck on your Vision.
 

·
Registered
Joined
·
273 Posts
Discussion Starter #10
Will do bowen! I will wait until the rebuild for the K&N filter...

Completed -
New Alternator
New Coil Pak
SilverStar lights
New valve cover gasket
Dealer installed plugs/wires
New Crank Shaft Sensor
Cooling System Flush
Fuel System Flush

Planned -
K&N Filter
Full Engine Rebuild
Full Tranny Rebuild
Wire/Hose Kits
(I should probably Do front end suspension while the engine's out... Huh... Hehehe)

Dream -
Do a RWD/5 Speed Conversion with an ol' Hemi

:)
 

·
Registered
Joined
·
175 Posts
Okay, that's fine.
 

·
Registered
Joined
·
9 Posts
iceman..lets talk about sterring lol... this is what I had to do
http://www.allpar.com/fix/intrepid-steering.html
read this about sterring..I have had to re build the whole entire front end tie rods ect....I am putting a new rack and pinion sterring in next 3 days..one recomendation for cheap fix..and good performace..make sure your transmission motor mount is in good shape 50 bucks from auto zone takes about .7 hours to put in ..I got mine replaced yesterday trying to pass safty and I almost get pulled back in my seat when i stomped it no-downshift till about 100 mph ..soo freckin smooth ..
 

·
Registered
Joined
·
9 Posts
bowen on your muffler let me know how you go...I been looking at a whole magna flow kit ...here is some other stuff I found on all par people taking about airflow adjustments

Steve Porter was happy with his K&N filter, saying:

The filter worked out great. It's a little throatier, and if you're doing say 40-50 and ya punch it, she really kicks in. I noticed a better shift, better throttle response and lots o' tire smoke (with traction control off).

Douglas Miske adds:

Owners with 3.5L engines can find a few free horsepower by removing the airflow restrictor found in the hose that runs from the air filter to the intake manifold. Simply disconnect the hose at the air filter end, reach in, and pull out the cone-shaped restrictor. The engine will sound throatier, and performance will improve above 4,200 rpm (when you're using the higher air flow short intake runners). Chrysler installed the restrictor mostly for sound quality, according to two dealers I asked.

Oliver Liu wrote:

I removed the airbox restictor, waited 3 days, installed a K&N air filter, waited 5 days, and then replaced the muffler (the large rectangular thing under the rear seats) with straight pipe today.

It sounds REALLY aggressive. The 3.3l engines have the muffler as well, but the 3.5l engine have a resonator after this (where the dual exhaust tips are). This is the only thing I have between the cat and the tailpipe now.

The airbox restrictor did almost nothing, the K&N was a subtle but nice change, apparent under hard accelleration. The exhaust mod is borderline obnoxious. NO CHECK ENGINE LIGHT comes on, this is a popular rumor.

Mark A. Chastain wrote:

I own a 1995 Intrepid, 3.5 Liter. I have read the articles here and followed them. The flow restrictor is gone, and the resonator has been replaced with a glass pack of the same size with two 2.5ID outlets so that it looks similar to stock. The sound is definitely better, and the improvement in response is noticeable especially while on the interstate.

I think everyone is missing an important issue. The rubber duct between the airbox and the fenderwell. If you haven't looked at it, you should. I estimate that the rectangular inner measurements are less than 3/4 inch high, and less than 5" long. I cut out that section, retained the ends and connected them with some cheap universal airduct purchased at the local car parts store. This opened the duct to a minimum of 2" high and 6" long. I made the other mods at the same time, so I can't say if this alone improved performance, but it seems to me that that duct is definitely restricting flow.
 
1 - 13 of 13 Posts
Top