DodgeIntrepid.Net Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
A friend has an early 90's talon turbo (not the tsi AWD model) that keeps blowing hoses. In fact, the last time it was a metal hose. The car has 113,000 miles on it, and I don't know its history. He wants me to look at it before they put it up for sale to see if there's some obvious reason why this keeps happening. Was this a common problem for those cars as they get up in age? Is there an easy solution like a way to bleed excess pressure from the system, or am I looking at problems with the head gasket or radiator?
Just thought I'd post this here since some of you D/C guys may have seen this sort of thing before.

Thanks alot
 

·
Registered
Joined
·
502 Posts
I can help you out...lemme hit you up with an email of my buddy with one.

Here's his email:
I already sent him one with the link to this post and your email, so expect something from him.

[email protected]

[ November 13, 2001: Message edited by: ATFCharger ]

[ November 13, 2001: Message edited by: ATFCharger ]
 

·
Registered
Joined
·
2 Posts
Keeps blowing hoses? Which ones? Never heard of this problem before...
 

·
Registered
Joined
·
502 Posts
ROFL...that's all you could reply?? I went through all that excruciating work to have you say, "which one?"

Sometimes I think your personal-squirrel isn't running quite right... :)
 

·
Registered
Joined
·
49 Posts
Discussion Starter #5
I haven't actually talked to him much about it yet, just his wife. He'll be back Friday and we'll go over the whole car. She left the key with me today and I drove it to the gym and back tonight... That car has issues, man! I hope they didn't pay more than two grand when they bought it a year ago. I'm sure not all early or high mileage talons are this way, but this one has been rode hard and put away wet... OFTEN
 

·
Registered
Joined
·
2 Posts
Let me know if there is anything I can do to help.
 
1 - 6 of 6 Posts
Top