DodgeIntrepid.Net Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hey All I have an 02 intrepid 2.7 and i was having an issue recently. While accelerating down a highway on ramp the other day the car made a loud noise then wouldnt go over 2450 RPM so after searching on here i find thats the limp mode limit asnd the cam sensor went bad so i went to the dealer since OEM sensors are the way to go and still wont rev over 2450 RPM. So could my car be a late production 01 motor and the sensors are different? Or did my timing jump and im screwed?
 

·
Premium Member
Joined
·
15,507 Posts
limp mode and cam sensor?? huh?,, please post the codes you had,, have etc...
 

·
Premium Member
Joined
·
17,324 Posts
limp mode and cam sensor?? huh?...
Is it really limp mode (i.e., tranny won't shift out of 2nd gear) - *OR* is it that the engine won't run over 2500 rpm with a bad cam sensor (because it runs off of crank sensor below 2500 and the cam sensor takes over above 2500)?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Is it really limp mode (i.e., tranny won't shift out of 2nd gear) - *OR* is it that the engine won't run over 2500 rpm with a bad cam sensor (because it runs off of crank sensor below 2500 and the cam sensor takes over above 2500)?
Your right its just the engine will not spin over 2500 RPM in any gear, because like you said the crank sensor is used for timing until 2500 RPM then the cam sensor takes over..

But back to my point, are these sensors interchangeable with the 98-01 2.7l cars? IF so then i might have an 01 style tone ring and then the 02 style sensor wouldnt work.
 

·
Premium Member
Joined
·
17,324 Posts
Parts pdf's:
'01 5016736AA
'02 4609089AF

According to www.wholesalemopar.com, they both supercede to 4609089AH.
 
1 - 8 of 8 Posts
Top