DodgeIntrepid.Net Forums banner

1 - 20 of 63 Posts

·
Registered
Joined
·
414 Posts
Discussion Starter #1
thank for viewing my 01 se i am open to any suggestions and comments.

01 with little over 63k miles..bought it when it only had 17k in dec. of 01.

first came with hubcaps..
then added es alloy rims..
and now for the winter (10/12/09) steelies.




i need to sand out these headlights lol


the alloys lol (like you guys dont know how it looks like lol) sorry for the horrible quality..

CLEAN! :banana033:

And now the steelies as of 10/12/09


my little photoshop lol


will have more pics maybe this weekend if the weather cooperates
thanks for looking
 

·
Registered
Joined
·
414 Posts
Discussion Starter #3
yea its a 2.7..currently i only changed the wheels as you can see in the pictures..first it came with the reg. hubcaps..then i got a free set of alloys and now for the winter i put the steelies on..
 

·
Registered
Joined
·
414 Posts
Discussion Starter #7
Very nice looking car!
looks nice except for the scratches of when some idiot:homoswitch: keyed my car on all four sides..now there are scratches basically going from one end of the car to the other and all 4 sides..
 

·
Registered
Joined
·
414 Posts
Discussion Starter #10
I love that colour on the Treps. Any future mod plans for it?
well i plan on putting on a spoiler, new exhaust, black bezel headlights, and if money is good and find a cheap motor...a 3.2 or 3.5 swap
 

·
nobags noswitches nofatbitches
Joined
·
1,014 Posts
not bad.. we all gotta start with a base. maybe we should do a meet, im just across from port huron, or come to on ohio meet in the spring (Danlisle) or a south western ontario meet next summer possibly.. nice tho
 

·
Registered
Joined
·
414 Posts
Discussion Starter #13
Nice lookin ride! Take care of that 2.7! Your close to the big Ohio meets, hope to see you at one in spring time!
thanks everyone..and im taking care of it the best i can..the only problem i have is the oil light keeps turning on at idle and when i press the accelerator it goes off. now i was wondering if i could try and put in some kind of oil treatment that would fix the problem.

and another problem (not with the 2.7 just the whole car in general) is that my power mirror switch is broken and would like to get that replaced.
 

·
Registered
Joined
·
414 Posts
Discussion Starter #15
^ i would love to get an es bumper.. I've been looking for a cheap one, preferably one that comes with the fogs as well.
 

·
Registered
Joined
·
414 Posts
Discussion Starter #16
*update*
just put on the hubcaps.. didnt like the look of the steelies...will have a pic in a few minutes..
 

·
Registered
Joined
·
414 Posts
Discussion Starter #17
it won't let me edit my original post so here it is..
(this is just for the winter, after im switching the tires off the hubcaps to the alloys and the alloys are going to be all year round rims.)
 

·
I hit **** with sticks!
Joined
·
37,433 Posts
thanks everyone..and im taking care of it the best i can..the only problem i have is the oil light keeps turning on at idle and when i press the accelerator it goes off. now i was wondering if i could try and put in some kind of oil treatment that would fix the problem.

and another problem (not with the 2.7 just the whole car in general) is that my power mirror switch is broken and would like to get that replaced.
Replace the oil sending unit. Very common problem. Make sure you get a Mopar sender, the aftermarket ones wont cure the light flicker.
 
1 - 20 of 63 Posts
Top