DodgeIntrepid.Net Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
202 Posts
Discussion Starter #1
So i'm pretty sure my battery crapped the bed on me. i went to start it this morning and i got the dead battery clicking sound from the starter. so i figured i just left something on in the audio system. no big deal, i just pulled the main fuse and hit my kill switch just to make sure. I got the car jumped and went to work. it's a 15 minute drive at 50+ mph, so i figured that would be enough to get some charge into the battery, as it wasn't completely dead. my stereo still turned on before i tried starting it. went to leave work tonight same thing happened. jumped the car, started up, but ran very dim for a few minutes till it charged up a bit. got home and ran for a few more minutes, about 25 total. turned the car off, tried to start it, and the damn things completely dead again.

this sound like a dead battery to u guys?

oh and i just replaced both the pos and neg terminals on the battery with brand new ones, about a week ago. i looked under the air filter and they are corroded to **** already.
 

·
Registered
Joined
·
475 Posts
i had a similar problem. Heard the clicking noise and jumped from the amp battery in the trunk. I just had a loose connection on my negative terminal (yeah, the one that you can barely see and have to move the battery to get to.....arggghhh). Anyway. I tightened that up, and haven't had a problem since!

But goto autozone or walmart and have them check everything for free...just in case
 

·
Registered
Joined
·
202 Posts
Discussion Starter #3
i know that all my connections on the battery itself are tight as i just replaced both of the battery terminals less than a week ago. i pulled the whole battery out and cleaned it up. there was a bunch of corrosion on the battery and only the battery mount, but i figured that it just hadn't ever been cleaned before. it cleaned up fine with some baking soda and water so i figured it was ok and put it all back together. everything was fine for a few days, and now this.
i'm gonna take the battery up to autozone tomorrow and have em load test it. any other ideas anyone?
 

·
Registered
Joined
·
152 Posts
wait to see what autozone says, but it sounds like its buying the farm...perhaps a diehard gold or optima is in order???? Only other thing is your alternator isn't charging the battery???? Have autozone check that also!
 
1 - 4 of 4 Posts
Top