DodgeIntrepid.Net Forums banner

161 - 180 of 304 Posts

·
Bitches be like...
Joined
·
16,618 Posts
Discussion Starter #165







Me and pops pouring over the FSMs. Had to get power to the fuel pump to get the two year old gas out.






Suspension 80% back together, just needs tie rod ends and pinch bolts installed, and sway bar.





All accessories installed, Radiator in, Wiring is still a pretty big mess, lots of work to get that buttoned up, then she's ready to fire!
 

·
1st Gen FTW - It's AutoMedic!
Joined
·
15,449 Posts
Also looked like fun to work with your Dad on the project. My dad's not a car guy, kinda despises car work, actually - but I miss working in the garage with my dad beside me, because he always likes hanging out in the garage and seeing something come to life like that. I envy you for that.
 

·
Bitches be like...
Joined
·
16,618 Posts
Discussion Starter #169
Also looked like fun to work with your Dad on the project. My dad's not a car guy, kinda despises car work, actually - but I miss working in the garage with my dad beside me, because he always likes hanging out in the garage and seeing something come to life like that. I envy you for that.
Yea, I had my Dad and one of my brothers there all day, (he's in the black hat in one of the engine drop in pics.) It was nice to spend the day with pops! He's got an 01 Mustang that he's souping up for autoX, he's pretty knowledgeable about cars in general, so it's nice to have him around in the garage. :D
 

·
Registered
Joined
·
6 Posts
I had an 88 Shelby Z turbo 2 with the intercooler, twelve years ago. Parts are even harder to come by for the turbo 2. Of the small number of Shelby's made; only a small percentage of them were turbo 2 that came off the production line. I had some trouble 12 years ago getting parts. Unfortunately my $600 project car cost me well over $3000 and I had to part ways. Best of luck with it. I know you will love the car, like I did mine. Side note, my son's middle name is Shelby.
 

·
Bitches be like...
Joined
·
16,618 Posts
Discussion Starter #171
I had an 88 Shelby Z turbo 2 with the intercooler, twelve years ago. Parts are even harder to come by for the turbo 2. Of the small number of Shelby's made; only a small percentage of them were turbo 2 that came off the production line. I had some trouble 12 years ago getting parts. Unfortunately my $600 project car cost me well over $3000 and I had to part ways. Best of luck with it. I know you will love the car, like I did mine. Side note, my son's middle name is Shelby.
15K of this style Shelby Z were made across 87 and 88. The only years the "Shelby Z" was made I believe.

.
.
.



well not as much done this weekend as I hoped. The wife got go out with friends on Saturday, which she doesn't get to do often, so I hung out with the kiddies instead of working on the car. Did accomplish the following today:

-Plumbed and mounted the vac block, hooked up most of the vac lines (all new.)
-I'm happy to report that I have figured out where every bloody connector on the engine harness goes, and re-wrapped about 80% of it. Still have to clean up the alternator harness and do some more work on the wires around the SMEC.


Few annoying changes from 87 to 88 that I still need to deal with:

-Air temp plug is different (hoping I can just pop one off of one of my three other intakes)
-Speedo senor plug is different. (that's just damn annoying. Gonna be a splice unless I can take a part the connectors. I hate splicing stuff!!)

I didn't realize it before but my 89 CB has a different oil pressure sender... Opps. so fortunately I have the right one on of my other blocks... I fear I may have sent flag terminal part of the sensor on the original one to the crusher.

This week I should have plenty of time to drop the column in and button up the dash wiring... and after the above stuff is done
it's time to see if this thing works.
 

·
Registered
Joined
·
14,942 Posts
-I'm happy to report that I have figured out where every bloody connector on the engine harness goes, and re-wrapped about 80% of it. Still have to clean up the alternator harness and do some more work on the wires around the SMEC.


I didn't realize it before but my 89 CB has a different oil pressure sender... Opps. so fortunately I have the right one on of my other blocks... I fear I may have sent flag terminal part of the sensor on the original one to the crusher.

This week I should have plenty of time to drop the column in and button up the dash wiring... and after the above stuff is done
it's time to see if this thing works.
Awesome news about the progress and you/Dad will get that oil pressure sender figured out.

Late!
 

·
Bitches be like...
Joined
·
16,618 Posts
Discussion Starter #175
Cant wait! That should be one of the best Daytona's in Michigan when you get done with it!
:highfive:

Awesome news about the progress and you/Dad will get that oil pressure sender figured out.

Late!
It's no biggie, just got to pop the one off my other block and put it on this one. I think I'll invite my dad out again once I get proof of concept here and it's time to tune with the enhanced fuel system and computer.

Hope the garage is heated, but thought I missed the key turn.

Get video when you go to fire it off.
It's not, it was f'ing cold last night. :sneaky2:
 

·
1st Gen FTW - It's AutoMedic!
Joined
·
15,449 Posts
Getting closer! You'll get them figured out.

About splicing, remember that dealers have had to splice the AC transducer connectors, and it works fine - dealers did it with adhesive lined shrink tubing in black, with soldered connections of course.
 

·
Bitches be like...
Joined
·
16,618 Posts
Discussion Starter #177
So let me meter my excitement by saying that fuel, some vac, a few sensors and the radiator are still not hooked up....

but I just turned the key and gave the motor a very healthy crank, a few of them in fact. Sounded very good. This weekend I'll button the rest up and we'll add some fuel to the equation.
 

·
Bitches be like...
Joined
·
16,618 Posts
Discussion Starter #179
[rant]

And the inevitable is now a reality. Just can't get the fugger to run. Few coughs and sputters but nothing consistent. I refuse to believe it's anything other than out of time, Despite the fact that I'm 100% sure it's in time. Gonna pull off the valve cover and get the top talking to the bottom. Oh how much I love putting the same thing together multiple times. Yay.

[/rant]
 
161 - 180 of 304 Posts
Top