DodgeIntrepid.Net Forums - Dodge Intrepid, Concorde, 300m and Eagle Vision chat banner

1 - 20 of 25 Posts

·
Registered
Joined
·
1,823 Posts
Discussion Starter #1
RAAAAAAAAAWWWWWWWWWWWWWWRGHHHHH :explode1:


So, now that I'm done venting. Put in my new lights. Spliced some wires, in the end, it all goes well.

EXCEPT MY Dash Clusters fuse blows, as soon as i put my lights on.


I'm going to take this as an assumption, that the HID lights I have installed are causing it.


Maybe?

Need some input you guis.


~Ken

PS I also have some headlights for sale possibleh ;)
 

·
Registered
Joined
·
1,823 Posts
Discussion Starter #5
My friend took the control of this one but...


We spliced the turn signal connector (took off the harnesses, so we could plug it in).

and we also for power to the halo's used the fog lights, and spliced into the wires to power them
 

·
Registered
Joined
·
8,218 Posts
Just for a test replace the fuse and then just turn on the marker lights no headlights to see if the fuse blows.

If it does you have a wire crossed at one of the marker lights.
 

·
Registered
Joined
·
8,218 Posts
If you now have led turn signals then yes you will need to install resistors or a led compatible flasher relay which i don't recommend because the flashers will cause the fuse to blow.

Also they will hyper flash without resistors or the relay.
 

·
Registered
Joined
·
1,823 Posts
Discussion Starter #17
So, basically run it like needing
Power and a ground? Lol



Also,
The ones I got were small, and were egg shaped... Do I need the box styled one?


Sorry, this is new to me
 
1 - 20 of 25 Posts
Top