DodgeIntrepid.Net Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hey there Ya'll. Has anyone blown a thermostat yet? I have a 93 Concord with the 3.5L. I lent the car to my bro the other day and It came back without heat! I was like what the f*#% did you do? Of course he didn't do it. It was quite easy to diagnose this one. I went to the local Crysler dealer and bought a new thremostat and a gasket.

The reason I am placing this little entry is becuase of the fact that I really did blow the thremostat. I went to remove it and wound up having to use vice grips and pulling with all my might. It turns out that the bottom of the thremostat broke off and the spring bent it right back so it jammed itself agains the inside of the coolant duct. I left a little bit of a scratch in there... hope it doesn't wreck the water pump with debris! DOH! I am going to take a pic of the thermo tonight and post for ya'll to see. HA HA! The joys of car ownership!

Take car ya'll :p
 

·
Registered
Joined
·
415 Posts
maybe that could have caused that tapping?? some of that crap falling down in there?
 

·
Registered
Joined
·
2,427 Posts
my thermostat went after grease monkey left the cap off my reservoir bottle when they checked the coolant. when i capped it a massive air bubble made its way to the thermostat and stayed there and the thermostat went out and i had to flush the system. but as for normal operating conditions, neither my 97 trep nor my company's old 3.5 corde had a problem with the thermo in that department.
 

·
Registered
Joined
·
4,811 Posts
Those grease monkeys are bastards like that :rolleyes: ...ever since i brought mine in for an oil change the lifts for the hood have been shot...pry just a coincidence but id rather blame it on them :D
 
1 - 4 of 4 Posts
Top