DodgeIntrepid.Net Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2003 intrepid with a 3.5 ltr.

I got the car with the engine light on, the code read camshaft position sensor malfuntion. I changed the sensor and the car ran great for 3 days. on my way home from work today it started to stutter at about 1/3 pedal and it is hard to start (I have to hold the pedal to the floor for about 3 seconds and when I let off it starts). The light came back on with the same code. Normally, I would say this is a fuel pressure problem, but the code is throwing me for a loop... suggestions?
 

·
I hit **** with sticks!
Joined
·
37,838 Posts
Sounds like the cam sensor may have went bad again. Check it and the plug and wiring to it.

There is a recall bulletin out about this, has to do with the cam sensors receiving too much voltage from the PCM IIRC, and causing them to fail repeatedly. It can apparently cause damage to the catalytic converters from the computer falling into a limp mode after it occurs.

There is a bulletin posted in this thread:

http://www.dodgeintrepid.net/forums/t164030/

This may or may not have something to do with your issue, first I would replace the cam sensor again, you may have gotten a faulty one.
 

·
Registered
Joined
·
3,934 Posts
There is a recall bulletin out about this, has to do with the cam sensors receiving too much voltage from the PCM IIRC, and causing them to fail repeatedly.
So they claim, however, I'll bet more than likely, it is the Chinese garbage that they are importing both factory & after market.
Quality is so poor, they cannot handle the 8 volts they are supposed to, so the PCM is reflashed to supply 7 instead, to make up for the crap.
Instead of fixing the problem, they just as a band aid to mask it.
 

·
Registered
Joined
·
8,464 Posts
I of all people have been chewing then son's of ***** sensors like none other. I got it reflashed the other day and so far (crosses fingers) has been ok. I was getting so bad that I had a ratchet in the center console ready to pull over, pop off the neg. terminal, chill for about 5 minutes, tighten her back up and was on my way.... Really annoying if you ask me.
 

·
Registered
Joined
·
22,212 Posts
I of all people have been chewing then son's of ***** sensors like none other. I got it reflashed the other day and so far (crosses fingers) has been ok. I was getting so bad that I had a ratchet in the center console ready to pull over, pop off the neg. terminal, chill for about 5 minutes, tighten her back up and was on my way.... Really annoying if you ask me.
I wonder if they would still do the recall for me since I had the 3.5 upgrade??
 
1 - 7 of 7 Posts
Top