DodgeIntrepid.Net Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
The main screen display works fine but the button LED lights aren't working. I took it all apart to see if anything was obviously broken but it all looks in tact.
On the main board it has LED 1 and LED 2 on the lower right.
LED 1 is lit but not LED 2.
Any suggestions on if this is fixable?
 

·
Woober Goobers!
Joined
·
49,877 Posts
What year and model car?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Sorry. 1993 Dodge Intrepid ES.
I have a picture of the board I just don't see where I can upload it to this board.
 

·
Woober Goobers!
Joined
·
49,877 Posts
I can't help you on that one. You've got a 1st gen LH 1993-1997 car. I've only got experience on the 2nd gens.

Heard there used to be a guy on Ebay that was a reliable source to repair the 1st gen Infinity stereos. Not sure if he's still around.
 

·
Woober Goobers!
Joined
·
49,877 Posts
Might be 1 or 2 knowledgeable 1st Gen people left on here but it takes a long time for them to respond if at all. They're a rare breed!
 

·
Woober Goobers!
Joined
·
49,877 Posts
Originally for both generations. 1993-1997 and 1998-2004.

Please realize the newest 1st gens are now 20 years old! Not too many of them around compared to the 2nd gens anymore. We used to have several very knowledgeable 1st gen members that shared information but they have moved on. That's why I said it was tough to find a 1st gen expert still around.

Your best bet is to do an advanced search and hope you find relevant information. Another issue is PhotoBucket cut off linking to pictures and a lot of threads don't have pictures anymore. That's not just for this site but many others. Complain to PhotoBucket.
 
1 - 8 of 8 Posts
Top