DodgeIntrepid.Net Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
'04 Concorde, haven't driven for a couple of months, started it up by pumping the pedal, starts but won't idle, stalls. I can press the gas pedal and keep the RPM's up, will run fine. There is a vacuum hose on the driver side of the intake that comes from a cone shaped piece that also has a cable to the throttle body, that when I remove the hose, the car idles fine, but as soon as I put that back on, it dies. What can I do? I tried to pull the Idle Control Module and clean it, but the plunger seems to be free and fine.
 

·
Premium Member
Joined
·
17,332 Posts
The cone-shaped thing is the cruise control servo.

When you say you remove the vacuum hose from that and it idles fine, are you closing off the free end of that hose?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
There is a vacuum line that comes off of that servo, goes towards the engine, there is a "T" in the line, one goes below the fuse box, the other straight into the side of the plastic intake cover. when I remove that vacuum line from the side of the plastic cover, and leave it loose, I can hear the vacuum sound out of the side of the plastic cover, but it runs fine with that open. As soon as I place the vacuum line back on the fitting, or place my finger over the fitting, which sucks the skin on my finger, the car dies.
 

·
Premium Member
Joined
·
17,332 Posts
Sounds like the IAC is not working, and it's getting the additional air it needs from that "leak" that you create when you remove the vacuum line. (Fuel adjusts automatically according to the air it does get based on O2 sensor outputs.)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
So I've pulled the IAC, tried to clean it with carb cleaner, the plunger seems to be free and working, I've cleaned inside the throttle body, what I can reach with carb cleaner and rag or toothbrush, can I remove the throttle body for better cleaning, or replace the IAC? If something is dirty inside the throttle body, hate to replace the IAC to have it do the same thing.
 

·
Premium Member
Joined
·
17,332 Posts
So I've pulled the IAC, tried to clean it with carb cleaner, the plunger seems to be free and working,...
Perhaps it is an electrical problem?

...can I remove the throttle body for better cleaning, or replace the IAC?...
Shouldn't be necessary to remove throttle body. Could try replacing the IAC - maybe try a junk yard part.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Changed the IAC but still have a code

So I replaced the IAC, pulled the battery cable to reset the codes, started up the car and went from three codes, 0443, 0508, & 0509, and now I just have 0509 remaining. Any ideas how to get that last IAC code to clear, and the car still won't idle, just stalls out. I did find that the PCV elbow was torn, so I replaced that as well, along with the PCV itself.
 

·
Woober Goobers!
Joined
·
51,017 Posts
Did you replace the IAC with another one or just re-install the original one?
 

·
Registered
Joined
·
744 Posts
Clean the throttle body .
Use a large swab on a metal rod to get in there and scrub it.
There has to be a fixed air gap as even IAC can't quickly compensate
for a closed throttle plate.
 
1 - 10 of 10 Posts
Top