DodgeIntrepid.Net Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
205 Posts
Discussion Starter #1
All,

I am in the middle of a noise investigation and stumbled upon something. When my front sway bar end links were replaced, what if they weren't properly greased on the passenger side using the fittings? Could a lack of lubrication in the joint cause the clunk when going over small bumps? Everything else has been replaced (struts three times already), could it be that simple that they forgot to grease that one?

Thanks,

Joe
 

·
Registered
Joined
·
205 Posts
Discussion Starter #3
What repairs have you had done so far?
 

·
Registered
Joined
·
8,218 Posts
If it was never greased i wouldn't think they would last very long.

I would remove the link and if the threaded ends are still tight in the socket and not flopping around there most likely fine but if there sloppy and easy to move around there shot.
 

·
Registered
Joined
·
205 Posts
Discussion Starter #5
I did notice that the noise was there almost immediarely after the initial strut/end link job was done. I'll be looking underneath tonight I guess.
 

·
Registered
Joined
·
24 Posts
I've done both front struts, control arm, tension strut bushing and both end link about two month ago and everthing was very quiet until i had to replace my driver side hub assembly and then started hearing that clunking nosie again
 

·
Registered
Joined
·
205 Posts
Discussion Starter #8
If that is the case, is the CV axle/joint a high price repair?
 

·
Registered
Joined
·
8,218 Posts
Im not sure what a shop would charge as far as labor goes but i just did my passenger side in about 2 hours.

You can get axles for around $70.
 

·
Registered
Joined
·
205 Posts
Discussion Starter #10
Is it the joint or the axle (or are they one and the same)?
 

·
Registered
Joined
·
205 Posts
Discussion Starter #12
no problem cryptkeeper. you have been very helpful through all this. I forgive you. :)
 

·
Woober Goobers!
Joined
·
51,016 Posts
Had my passenger side CV axle replaced on the Special. I was charged one hour of shop labor. I supplied the axle.
 

·
Premium Member
Joined
·
17,326 Posts
If you get the half shaft from Advance (GSP brand), check it well. The one I installed a few months ago lost all of its grease in one day from the outer joint because the boot clamp was not tight and that end popped totally loose. About the same time, at least one person (I forget who) and maybe a second person posted that they also got defective ones.
 
1 - 15 of 15 Posts
Top